Bluetooth Speaker Plugin

I followed your previous post (20 days ago) to install the plugin.
The bluetooth speaker does get the audio signal but I can’t manage the volume at all (nor through the webUI nor through the physical buttons of the wonderboom). It’s always at full volume.

I guess I used the updated Bluetooth Manager plugin.
How can I help you troubleshooting this ? I can’t send you my speaker :stuck_out_tongue_winking_eye:

Edit :
Oh, i tried again today after rebooting the raspberry and the speaker. Once connected to the bluetooth, it works …
I guess it’s solved … ^^

Hi.
I’ve updated Bluetooth Manager plugin for volumio3.
Same as previous, it is strongly recommended to try it with clean Volumio3 image not to break your environment already working.

The improvement from previous version for volumio2 is supporting volume control from GUI. Please note that since it is implemented as software volume, full bit output is available only when GUI volume is set to 100%. The volume control in bluetooth device side still works separately.

I confirmed it works at VERSION 3.165 with Raspberry Pi 3 ModelB+ and Raspberry Pi 4 Model B.

Here is the install process: (for volume3 only)

Download zip files below:
bluetooth_controller.zip (4.2 MB)
www.zip (4.5 MB)
www3.zip (6.9 MB)
www4.zip (6.9 MB)

Access http://volumio/dev/ and enable SSH.
From your local machine (Git Bash etc)

$ scp www.zip www3.zip www4.zip volumio@volumio:~/
$ ssh volumio@volumio

After ssh login

$ cd /volumio/http
$ sudo mv www www_bak
$ sudo mv www3 www3_bak
$ sudo mv www4 www4_bak
$ mkdir www && cd www
$ miniunzip ~/www.zip && cd …
$ mkdir www3 && cd www3
$ miniunzip ~/www3.zip && cd …
$ mkdir www4 && cd www4
$ miniunzip ~/www4.zip && cd …

Access http://volumio/
Settings → Appearance
Switch User Interface Layout Design from “Contemporary” to “Classic” → Save

Settings → Plugins → Upload Plugin
Drag and Drop bluetooth_controller.zip
Please wait patiently as Plugin Install progress will hold at 70% for a long time.
It will finally finish within 30 min with Raspberry Pi 3 ModelB+ and Raspberry Pi 4 Model B.
Then click Enable Plugin. At this timing, you’ll see Bluetooth Manager is still inactive.
After plugin installed, you can switch UI to “Contemporary” or “Manifest” if you want.

Then reboot Volumio once.

After rebooted,
Settings → Plugins → Installed Plugins
Now you’ll find Bluetooth Manager is active (in green lamp)

Settings → Plugins → Installed Plugins → Bluetooth Manager → Settings → Bluetooth Devices → Refresh
Click Connect beside target bluetooth device
Refresh several times to confirm if selected device is connected.

Thanks.

Added on Dec. 11th:
For clarification, this is an unofficial plugin. It could harm other features.
Please try under your own risk.
(@balbuze, thanks for follow up comment)

1 Like

Thanks for your work.
But I need to bring some precisions::
Using this plugin will prevent you to update volumio.
It is not a plugin as defined for Volumio.
What do you think of making a ‘true’ plugin, conform to requirements?:wink:

1 Like

@elehobica that’s some impressive work. Thanks!
Got that working on my Pi Zero 2. Installation took ~15min, pretty straight forward. I’ve managed to pair Sony WH-1000XM3 headphones without an issue.
Interesting that I couldn’t do the same with Ikea’s Eneby Portable. It’s in a constant pairing mode if not already connected to any other source. I could see this device for a brief while… oh wait. I just did but the connection seems to be really poor (though both Pi and speaker are next to each other). Guess I’ll have to work on a line-out to keep it reliable

1 Like

Hi there,
I’ve been following the “Bluetooth Speaker Plugin” project with interest for a long time. In the meantime I have deactivated my installation on an RPi Rev. B and i am on the road with a new installation V. 3.165 on a Pi Zero 2 W. I implemented the Bluetooth plugin according to @elehobica 's instructions. It all worked so far. I have the following products available for testing: 2 x JBL Flip 4, 1 x Yamaha Soundbar YAS-109 and a Jabra Evolve 2 65 BT headset. I notice the same problem with all devices: A connect with the BT plugin is possible, but there is no audio playback. Does anyone have a tip for me.
Greetings Andreas

Thank you to @geeks-r-us , @elehobica , and everyone else who has contributed to the bluetooth speaker plug-in.

I’m enjoying your work, but I have encountered a mysterious behavior.

For some reason, Tidal track information does not display properly when using the plug-in.

Instead, a string reading 0.flac? is displayed.

I’m running a Pi Zero 1 W with no DAC or any other acoutriments and have repeatedly reproduced this with a fresh install of Volumio v3.198.

Before installing the plugin, music plays over HDMI fine and the track info displays as expected.

After installing the plugin, music plays over both HDMI and bluetooth, but for Tidal tracks, the track info instead displays 0.flac?'<some long token-y looking string>'

Does anyone have any insight or workaround suggestions?

Hi there,
I installed the BT Speaker plugin as described on a Pi3 B with Volumio 3.165. My BT Device JBL Flip 4 connects. The audio output works. After restarting the RPI, I have to connect the audio device manually via (“Connect”) in the BT plugin. Can the connection be performed automatically?

Greetings Andreas

Has anyone made this work for the newest Volumio3 release (3.233)? I get to the point of rebooting and get a blank screen and “not found” with no ability to connect to the Rpi (essentially it bricks the OS).