Bluetooth Input Playback Issue

I managed to connect my Android Phone to Volumio’s Bluetooth Input Playback. However, I am getting terrible noisy sound out of it - not bad like in difference between MP3 and CD, but more like FM radio in an underground parking garage - mostly noise, barely identifiable music.
I had this issue with 16-bit sources, for which the solution was to resample to 24-bit using Volumio’s Playback Options. However the Bluetooth input seems to bypass the resampler. Could this be the case? If so, can this be fixed?
Thanks in advance for the help!

Some background info: My DAC (PS Audio Stellar Gain Cell DAC) had to be repaired, during which a new mainboard was installed. PS Audio says that the Firmware revision for that new board has issues with Volumio - my issue is that I couldn’t connect at all using USB!!! I had to add an “I²S over HDMI” module to my RPI 3+ to connect via the I²S port, with the caveat that it will only play very noisy 16-bit audio. 24 bit plays perfectly, as does DSD

Hi David,
bluetooth outputs at 16bits (this causes the issue as you explain) and unfortunately there is no way to enable resampling on it…
Can you ask PS Audio to update your firmware to not have issues with Volumio?

I remember I wrote :
I made a test and BT is well resampled…
But it’s a beta plugin…
So you can try, but don’t expect a new work on it…
An (better) other working way is to use : and set Dirac pulse or none a filter and the samplerate you want

I have a similar issue. My setup is: RPI3B-Kali-Piano 2.1. I am trialing My Volumio Virtuoso and Bluetooth streaming from my iPhone SE. After a few minutes of playback I hear distinct crackles and pops in the music. DSP for Piano 2.1 is set to 2.0 output, resampling to 32 bit depth and native frequency. Any ideas why the crackles and pops happen?

Same issue with a pecanpi DAC and quite completely sure the DAC is fine since every other source play fine

I changed the I2S profile on Volumio from Generic I2S to R-PI DAC and that did the trick. Now I can completely disable resampling and it (PS Audio Stellar GCD) will play 16, 24-bit, and Native DSD without issue.