black screen, no network...not working?

Hi all, just subscribed to the forum, as I can’t seem to be able to get my raspy run volumio, which is a huge pity.

Let me summarize. Equipment:

  • Raspberry Pi type B and 2B
  • 2 sd cards 4 Gb
  • HDMI screen
  • Volumio 1.55

So, I download, extract and dd the image to the sd card, no problem in this.
Then I put the card in the raspy, turn it on and it doesn’t seem to do much: the green light blinks for some 15 seconds, then nothing happens.
The screen turns somehow on (it stops the energy saving mode, so it must sense something…) but remains dark.
The ethernet lights do turn on, but my router doesn’t release any new address.
No clue on what this could be.

I tried with 2 different raspys and 2 different cards and the problem remains., I downloaded again the file and tried again and no success.

My impression is that the startup does not complete, as the blinking green light doesn’t blink for long, at list way less then pure raspbian.
How to find the reason? Anyone else with the same problem?

Thanks a lot,

p.s.: downloading ver. 1.51, in order to chek if another version works, if I don’t write again, no success

Just un update to say that 1.51 works.
The issue must be in the 1.55 image, at least the 2 i got…

I get the same issue than turtaf.
The version 1.55 (8 feb 2015) boot, but I can’t reach the web interface “volumio.local”.
The MAC/IP of my raspberry pi type B (512MB) is not listed on my router interface. It seams there is not DHCP request from my Raspi.

I put an USB/serial converter to watch logs printed at the boot.
Traces displayed seems Ok (I don’t have logs with me right now. but I can provide those log if needed)
The kernel run without obvious issues.
The smsc network drivers are loaded and run.
But nothing after. As if init process was blocked in a dead lock or something.
One more thing: there is no activity in /var/logs directory thus i can’t get any details on what really happens in init.

Also I can’t get a terminal up on the USB/serial interface, to proceed further analysis.

Here is what i do (maybe i’m wrong) :
in /etc/inittab i uncommented the line below:

#Spawn a getty on Raspberry Pi serial line
T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

But nothing happen.


There is something you can do but it requires manipulation of files on the SD card.
Insert the SD card into your linux machine and do a FSCK on the first partition (fsck -fy /dev/mmbclk0p1). Mount the partition and edit the config.txt file, insert the line


You have more options here:
Unmount the partition and mount the second one.
In the etc/network/interfaces files, instead of “auto eth0” put “allow-hotplug eth0”. You can also put a static IP address instead of DHCP:

allow-hotplug eth0 iface eth0 inet static address netmask broadcast gateway dns-nameservers dns-search dns-domain

Change the content of the etc/fake-hwclock.dat, put a date in the future (10 or 20mn more than the actual hour).
Unmount the partition and try to boot the Pi.
I am using a Pi B with 256MB and 1.55 works quite well.

I followed both steps:


And it works fine now ! :slight_smile:

Thanks ! :wink:

First of all, sorry that I dig this old thread out of his grave.

But I have the same problem.
I have 2 Raspberry Pi B and 2 4 Gb SD-Cards. I’ve tried to install Volumio 1.55 on both of these Cards and on both Pi’s with both SD-Cards I only get a black screen and no network connection.

I’ve already edited the fake Clock file and inserted the HDMI Hotplug in the config file. But it won’t boot as well.

Does anyone have the same problem, or any idea how I can solve this?

Many thanks in regards!