Beocreate board from HifiBerry

i move my request here from “Suggest a feature” section.

I 've recently configured the new board from HiFiBerry Beocreate ( from Bang & Olufsen ) on the B&O CX50 loudspeakers:
Great product! delivers very clear audio using Raspotify, Shairport-Sync, Optical output and Bluetooth .
I’ts programmable by DSP tools from SigmaStudio ,
but you can use the Beocreate board with practically any software. However, there are some limitations:
You won’t be able to upload or modify DSP programs
You won’t be able to change DSP parameters on the fly

the Beocreate board “should” work with no problem with Volumio,
this is the answer from the team HIFIBerry:
“If you just want to program the board without changing parameters at the runtime, you can do this just with the Beocreate software. The profile will be stored on the EEPROM and will be automatically activated after a reboot, even if the DSP tools aren’t installed.”
so , basically, you need to setup the board with the right DSP profile (using the Beocreate software) then swap the sd with a Volumio distro and it should work.
The “should” needs to be verified, because if i change the profile to HIFIBerry DAC from within the Volumio web interface at: volumio.local/plugin/audio_inter … controller
i can’t hear no sound
the board is full working with Beocreate software,

this is the : aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

Subdevices: 8/8

Subdevice #0: subdevice #0

Subdevice #1: subdevice #1

Subdevice #2: subdevice #2

Subdevice #3: subdevice #3

Subdevice #4: subdevice #4

Subdevice #5: subdevice #5

Subdevice #6: subdevice #6

Subdevice #7: subdevice #7

card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

Subdevices: 0/1

Subdevice #0: subdevice #0

I’re done the reset to default settings on Volumio, switched off then on the i2s option etc etc…
any idea?

There is a minor mute switch on this board. Perhaps is on mute.

if i use the beocreate sd the board play sounds , if i switch it with a working volumio sd ( from another raspberry pi 3 board with hifiberry DAC ) doesn’t play any sounds, do you think could be the mute switch, sound weird…it should be muted all the time with all the software on the sd

Sorry but I don’t have the Beocreate, so can’t help you.
Your best bet would be asking hifiberry

this is their response…

I think it’s a project in an initial state, so I have to do other tests or wait for other users to apply,

Maybe this board requires hifiberry dac plus.

Can you post the content of their sd image’s /boot/config.txt here?

For more options and information see

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode


uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display’s size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Uncomment some or all of these to enable the optional hardware interfaces


Uncomment this to enable the lirc-rpi module


Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)


Ok, so try this in your Volumio image, add to config.txt (and remove any previous dtparam added)

dtoverlay=hifiberry-dac dtparam=spi=on

so … removing the mute jumper (thanks Ingo Stormfrom the Hifiberry forum) and reinstalling from scratch now volumio works (very) well, I had been deceived by the fact that with the beocreate software it was not necessary to remove the jumper

Do you mind writing down the exact procedure that you did to make it work with Volumio?
I’m asking because it might be useful for others.

Then, how do you like the beocreate?

-installed on the beocreate board the software from B&O ( following the guides on the hifiberry site) setting the exact loudspeakers i hown ( in this case CX50)
-removed the jumper “mute” on the beocreate board ( this is essential…):
It is the no. 4 in the second picture on this web page: … mentation/

-installed the latest iso from Volumio(2.368) on an sd then swapped the sd with the original beocreate software used to initial set with the volumio one,
changed the setting in
volumio.local/plugin/audio_inter … controller
with I2S DAC to on and choosed Hifiberry DAC
choose the mixer tipe Software be careful to set a low default volume in this setting, the board it’s setted to a very loud volume at the beginning!

-nothing else…

I like the Beocreate board very much ! i’m an early beta tester for this board, paired with the B&O loud speakers CX50 - CX100 give some good, cool “retro look” now i’ve this two loudspeakers in my shelf and all in one solution it’s great!

Hi i’ve followed this procedure but between one song and the next one the system produce a very loud pop!

That has to do with the speaker profile that is installed. You can find a lot of info on this issue on the Beocreate community.

It has taken a lot of discussions, but I now have a Beocreate which works as a charm with Volumio

I followed tigroz’ procedure but cannot get sound from the Beocreate board with Volumio.

Booting from the HiFiBerryOS card, I get sound via AirPlay. Speaker Profile is “Other”.

Booting from the Volumio card, everything looks fine (like in my other Volumio systems), I choose “HiFiBerry DAC” as DAC Model and as Output Device; I2S DAC On, Mixer Type Software. I can play music from local storage, Volumio shows cover as expected; I can change volume, but there is no sound from the speakers.

Adding “dtparam=spi=on” to config.txt (as suggested by Michelangelo) makes no difference.

Maybe someone could post their working Volumio config.txt?


Hallo zusammen,
Gibt es hierzu schon weitere Informationen bezüglich der Beocreate Installation?
Auch ich habe genau wie mein Vorredner die Anleitung befolgt, jedoch bekomme ich keinen Ton.

Vielen Dank schon mal.

please in english :wink: