Bad system hang - please help!

Brand new install of Volumio on CuBox-i4pro

Linux volumio 3.14.79 #2 SMP Sat Jan 28 19:39:16 CET 2017 armv7l GNU/Linux

My music library is mounted via eSATA on /mnt/ESATA
/var/lib/mpd/music/USB -> /mnt/ESATA/Music

The external drive is EXT-4.

What happens - through the web interface, I see no music, so I use My Music > Update to add it.

This proceeds to add music for awhile, getting about 1/4 of the way through the collection.

Then the web interface goes away, being replaced by the circle of spinning dots. Simultaneously on the console I receive this message:

systemd-journald[257]: Assertion ‘s->type == SOURCE_ID’ failed at …/src/libsystemd/sd-event/sd-event.c:1792, function process_io(). Aborting.

Plus more messages about systemd-journald.service entering failed state, volumio.service being killed, etc.

At this point the system is so borked I cannot issue a “sudo halt”. Needless to say networking is down etc. I am able to do some things but sudo definitely not. So I retreat to a sync; sync; sync and pulling the power plug.

Other than taking a photo of the screen I don’t know how to save the messages generated; so here is a link to the screen shot:

Thanks in advance for any help!

EDIT: further to the above, I have just finished trying the same drive via USB, and also a completely different drive via USB.

In some cases I get kernel panics, alone or along with the systemd journald problem.

The most recent says

BUG: soft lockup - CPU#1 stuck for 21s! [jdb2/mmcblk0p3-:219]
Modules linked in: nfsd xt_REDIRECT etc etc

CPU: 1 PID: 219 Comm: jdb2/mmcblk0p3- Tainted: G D 3.14.79 #2
task: da48d800 ti: da716000 task.ti: da716000
PC is at __mem_cgroup_commit_charge.constprop.15+0x2a4/0x2c0
LR is at __mem_cgroup_commit_charge.constprop.15+0x30/0x2c0


I have photos of these too (in the case when the kernel panics there is no more console shell left reading commands).

Yes, we now have a number of similar reports where volumio crashes while scanning the music library on a cubox-i4.
It is an issue we had on several different platforms which we resolved with an mpd update a few weeks ago.
Unfortunately, the cubox-i4 still has probems. I’m investigating this, but to no avail sofar.

One pathetic update on this… I thought it might be SD card with a bad block or something, so I grabbed a new class 10 SD card this morning and tried it out. Same problem.

So good luck; and if there’s anything I can do to help please let me know!

I am wondering if, since Volumio 2 clearly does not work on CuBox, it is responsible to still have it available for download with promises of simple setup and the like. Isn’t it just inviting people to enjoy a free headache? Why not make Volumio 1.5 available again? At least it worked.