Backlight not turning off when screen saver triggers

I’m trying to understand why the backlight is still on this little 4" screen when the touch screen screensaver timer triggers. The screen is blank (all black pixels), but it is very clear the backlight is on. Just finished installing Volumio and the touch screen plug in for the first time, so I’m still getting used to it.

What can I tell you to help solve this little issue?

Raspberry Pi 4B, 8GB
Screen: 4inch HDMI Display-C - LCD wiki


hdmi_cvt 480 800 60 6 0 0 0

Thanks for your time.

Schiit Modi3+ DAC, Elekit TU-8500 preamp, homebuilt ST-70 amplifier.

Try adding


to /boot/userconfig.txt.

1 Like

Thanks for the quick reply.

According to: HDMI screen blanking but not switching off backlight - Pi 4 · Issue #3050 · raspberrypi/linux · GitHub hdmi_blanking=1 support on RPi 4’s is included in latest official software (February 2020). So the real question: Has Volumio taken this change as well?

Guess I’ll give it a try tonight and report back :slight_smile:

The change you mentioned is in the firmware of the Pi 4 itself. To my knowledge updating this firmware is nothing Volumio handles.

Hmmm, so it does - guess I thought that was part of the OS. You wouldn’t happen to know how to check the firmware and/or update it to the latest official bits (not pre-release)?

Still getting used to this little piece of hardware… Also need to figure out how to calibrate the touch screen, as it doesn’t seem very accurate or responsive. Oh, so much learning :slight_smile:

The Systeminfo plugin shows the firmware version.

Regarding updating: I did update a Pi4 only once and do not remember the steps in detail, just that I did it from Raspberry Pi OS not from Volumio. Edit: Not sure, but probably I followed

1 Like

Well, hdmi_blanking=1 yields interesting results. When the screen saver kicks in, the screen turns off, then turns on, then turns off - just constant blinking. The pixels are all black, but the backlight just keeps flashing on and off at about a 1 second interval.

This is the same behavior I see when (without the hdmi_blanking setting) when I tell Volumio to shut down. It shuts down, but the screen just blinks in the same way.

Hm, can’t replicate that here testing with an Eizo CS270 connected to HDMI 0 of a Pi4 2GB.

Where do you have your display connected, to HDMI 0 or HDMI 1?

Also please post the result of

cat /boot/config.txt

The left micro-HDMI port next to the USB-C power connection.

volumio@volumio:~$ cat /boot/config.txt
initramfs volumio.initrd

include userconfig.txt


That’s HDMI0 :slight_smile:

config.txt looks good, too.

I had another look at the wiki page you had linked above. According to the wiki your display has a backlight adjustment button to adjust brightness and switch the backlight on/off.

I could imagine that this prevents the backlight from turning off permanently as long as you don’t press the hardware button. In this case, there would be no solution that could be achieved with reasonable effort IMHO.

Another reason for your issue could be the hdmi related entries in the userconfig.txt. I know that the values you are using correspond to those one can find in goodtft’s GitHub repo, so appears unlikely that changing them would improve something. But if nothing remains it may be worth a try to remove config_hdmi_boost and all hdmi_* related lines except hdmi_blanking=1 and test if the display (a) still works and (b) backlight control behaves better. But expect nothing. :wink:

“Expect nothing” - HA!

Yeah, I’m starting to think this little screen is just incapable of following energy commands. I’ll try all of these suggestions. Thanks again!