Audio play stops after a while

Hi

I have RPI3 + Hifiberry DAC+ and i have some trouble with playback.
The archive is a NFS mount. Roughly 30 000 songs. Mixed mp3, flac and wav.
It’s been used since version 1,55 with Hifiberrys setup installer and been working great.
But on this last version 2.041 i have issues with playback stopping after a while.
Sometimes after 1-2 hours and sometimes after 10-15 hours. Completly random.
I see no connection drops since i’m connected thru ssh all the time.
I have tried running thru eth, internal wifi and an external usb wifi dongle.
Same issue on all 3 so this can not be a network error right?

Anyone know where i can start looking for errors?
dmesg says nothing unusual except alot of “pcm512x 1-004d: No SCLK, using BCLK: -2”
I did not change passwords.

Difficult one to diagnose. If you’re connected by ssh though you could leave:

journalctl -f

running in the background and have a look for errors when you get a problem.

Hi chsims

Thank you for the fast reply. I have issued this cmd and started the player with only one volume queued.
If this works for 2-3 days i will add my usual list which is 221 albums and see how it works.

tia thug

I have ran some tests last few days and this seems like it have to do with number of songs added to the que.
The sound stops during playback.
Webgui shows seconds still in a song. But it keeps changing songs still.
And on each song it stops on different time.
But after first stop no sound is ever heard anymore even tho it changes songs and stops in the middle or so.
I can not find any other errors in log but beeing unable to get album art.

If i go to webui and press forward to skip song this as starts over.
It plays a few hours then stops again.

And i just noticed while watching journalctl that when it changes song i went to webui and song shows stopped at 4.05sec
Full song is 4.11 sec but it didnt pass that long since when i saw change in journalctl i went to webui within seconds.

Anyone else experienced trouble with long playlists?

Yes, I experience the same here with a long playlist on pine64 and Udoo Quad, so it is across platforms.

Glad to hear i am not the only one.
Question is how do we do to solve this forward. I can not find any errors anywhere.

I have a similar problem with a RPi3. I start a big playlist and after 2-4 songs it just stops and I have to press play again to resume playing. This happens often.

Looks similar to issue described here
When sound stops, is your NAS still listed in mounted devices list on Volumio UI ?

Hi vigo,

Thank you for your reply. The NAS is still listed yes. I just have to press play to resume on new song and it works again for a while.
Last night i upgraded to last version.
I did a clean install not a update and i must say so far this is no good development.
I add 3 albums in que (15 songs each) and it plays one song then stops. (Random enabled)

Following are the last lines in log:

2017-03-04T11:45:44.249Z - info: Pushing Favourites {“service”:“mpd”,“uri”:“mnt/NAS/domace/- Razni Izvodjaci/Pesme Za Sva Vremena - 2013 - Vol. 2/04 - Srebrni Voz - Gde Si Duso.mp3”,“favourite”:false}
2017-03-04T11:45:45.895Z - info: CALLMETHOD: audio_interface upnp stopUpnpPlayback [object Object]
2017-03-04T11:45:45.896Z - info: CoreCommandRouter::executeOnPlugin: upnp , stopUpnpPlayback
2017-03-04T11:45:45.896Z - info: Stopping playback through UPNP
2017-03-04T11:45:45.897Z - info: [1488627945896] CoreStateMachine::setConsumeUpdateService undefined

Anyone have same trouble?

I am having the same problem after upgrading from ver 2.041 to ver 2.114 today. I never experienced this problem in ver 2.041 with several thousand hours of playback.

System setup: Pi 3, HiFiberry DAC+, 30K+ song list, external HDD connected to Router (NAS), random play, GPIO plugin, WiFi connection

Same here…

Hi

Same problem with new version.
Clean install no plugins no nothing. Just simple nfs mount.
Queued 380 mixed mp3/flac/wav files.
It played 2 songs then stopped. Random is on.
Logs look like it’s playing because it’s switching songs every few minutes but there’s no sound coming.

Anyone know how i could troubleshoot this?

tia AC

Same here with pi3, hifiberry dac+ and external usb drive. Long random playlist (16.000 songs), playback stops after 1-3 songs and resumes after I press play or next button. I did a fresh installation with touch display plugin enabled. Connection is with wlan.

I’m seeing this, too.

RPi3, HifiBerry Digi, and I’m playing music (mp3) from a USB stick plugged into the Pi.

same me. volumio 2.118, fresh installed. usb stick 8gb plugged.

Sent from my SM-G610F using Tapatalk

I also experienced intermittent stop play back even playing radio or local usb stick. sometimes it can play whole night but sometimes not. Restart Volumio cannot fix. I have to repower. Mine is raspberry pi 2+ and hifiberry dac plus. volumio 2.118 fresh installed.

Update 1: When playback suddenly stopped, I’ve noticed that the DAC device was loss from Output Device setting.
My output device should be: Hifiberry DAC Plus
One press on Play button will resume playing.

Update 2: Even my output device has not listed in the Output Device setting, I still can play the music. Do not know why it stops.

Update 3: I think I can reproduce this playback stop.
alsa_controller3.JPG
Entering the dev mode (volumio.local/dev), while it’s playing, press Stop button. Now the seek value is increasing but no sound.
All Play, Pause, Stop, Prev will not work at this state. Only NEXT button do the trick (Volumio will start to play new song). Something wrong with MPD?

Sent from my SM-G610F using Tapatalk
alsa_controller2.JPG
alsa_controller1.JPG

For me the output device is not lost. Maybe this is 2 different problems we are experiencing.
I can now see that after it stops playing. I can login to web interface with a few minutes in between and
i see it is changing songs like it is playing them but the seconds are still on the interface and there is no sound.
Every time i refresh i see seconds have moved.
Both NFS shares are mounted and working.

Same error here.
VERSION: 2.118 with USB DAC

hi !

same here :

rpi zero W + 2.118 Volumio + NAS (Openmediavault) + FXAUDIOD802 USB

Same error! Rpi3 + i2s dac and version 2.118 (started with this update)

Tapatalk kullanarak iPhone aracılığıyla gönderildi