Audio Out of Headphone Jack

Hi everyone,

I flashed the armhf port of Volumio to my Rock64. I followed a 3rd party guide to install Volumio and SnapCast: Multi Room Audio - Pine style

Everything works great ( I can see traffic coming across ethernet port, iPad shows AirPlay working) except I cannot get Volumio to play the audio through the 3.5mm / headphone jack. Volumio does not list the headphone jack in the ouput devices. I only have HDMI, I2S and SPDIF.

using the CLI, if I run the speaker-test (speaker-test -c2 -twav) command, I get audio out of the headphone jack.

aplay -l lists:

null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
snapConverter
writeFile
snapcast
default:CARD=HDMI
HDMI,
Default Audio Device
sysdefault:CARD=HDMI
HDMI,
Default Audio Device
dmix:CARD=HDMI,DEV=0
HDMI,
Direct sample mixing device
dsnoop:CARD=HDMI,DEV=0
HDMI,
Direct sample snooping device
hw:CARD=HDMI,DEV=0
HDMI,
Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=0
HDMI,
Hardware device with all software conversions
default:CARD=I2S
I2S,
Default Audio Device
sysdefault:CARD=I2S
I2S,
Default Audio Device
dmix:CARD=I2S,DEV=0
I2S,
Direct sample mixing device
dmix:CARD=I2S,DEV=1
I2S,
Direct sample mixing device
dsnoop:CARD=I2S,DEV=0
I2S,
Direct sample snooping device
dsnoop:CARD=I2S,DEV=1
I2S,
Direct sample snooping device
hw:CARD=I2S,DEV=0
I2S,
Direct hardware device without any conversions
hw:CARD=I2S,DEV=1
I2S,
Direct hardware device without any conversions
plughw:CARD=I2S,DEV=0
I2S,
Hardware device with all software conversions
plughw:CARD=I2S,DEV=1
I2S,
Hardware device with all software conversions
default:CARD=SPDIF
SPDIF,
Default Audio Device
sysdefault:CARD=SPDIF
SPDIF,
Default Audio Device
dmix:CARD=SPDIF,DEV=0
SPDIF,
Direct sample mixing device
dsnoop:CARD=SPDIF,DEV=0
SPDIF,
Direct sample snooping device
hw:CARD=SPDIF,DEV=0
SPDIF,
Direct hardware device without any conversions
plughw:CARD=SPDIF,DEV=0
SPDIF,
Hardware device with all software conversions

“aplay -l” does not list that, you must have used “aplay -L”.
Please repeat “aplay -l” (lower-case l)

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDMI], device 0: ff000000.i2s-i2s-hifi i2s-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: I2S [I2S], device 0: ff010000.i2s-rk3328-hifi rk3328-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: I2S [I2S], device 1: ff010000.i2s-snd-soc-dummy-dai snd-soc-dummy-dai-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SPDIF [SPDIF], device 0: ff030000.spdif-dit-hifi dit-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I managed to get this working by:

General Playback Options:
Audio Output
Output Device: I2S

SnapCast Configuration:
SnapClient Settings:
Soundcard to use for Playback: Omit soundcard parameter

Volumio Sound Config-
Ouput Device: ff010000.i2s-rk3328-hifi rk3328-hifi-0 (copied from Soundcard to use for Playback)

so all ok with headphone out?

correct. no longer an issue. thank you!