Audio keeps cutting out [Spotify and Webradio]

Please help, this is cool and I really want it to work

Sometimes I’ll be lucky to get 30 seconds of audio (following a reboot), before it cuts out.
The timer on the main page carries on counting etc and it appears that the player assumes business as usual. :confused:

When the audio does return (approximately) 20-30seconds later, it’s not at the point it cut out.
This keeps happening over and over and eventually you just have to give up. You can’t listen to a full song.

I’ve tried playing with buffering settings etc
Also tried increasing the cache-size as suggested by people struggling with similar issues before…
Tried 2 SD cards both are Class-10
fresh installs
updated

Please, if anyone has any ideas, or could help in anyway, it would be greatly appreciated. As mentioned above, I really want this to work.

Hi,

What hardware are you running Volumio on? Also how is your box connected to the network? Are you sure it’s not in the connection between the DAC and your audio?

Hi
Have you tried using a RAM cache instead? That’s worked for me. The below instructions was used on Volumio1 so I can’t guarantee what will happen in Volumio2.

$sudo nano /etc/spopd.conf
Add this line under [spop]:
cache_path = /run/shm
Save the file and restart.

Please tell us which Raspberry PI you use, which Audio device you use and your Power supply

Hi

It’s a Rasp Pi 2B+ standard.
One other thing I tried was HDMI out (instead of Audio Jack) and the problem followed.

I haven’t tried the RAM cache idea, so I’ll give that a go.

Many thanks much appreciated :smiley:

It’s wirelessly connected and using an official Raspberry Pi PSU

Ok, so you’re using the Audio Jack…

Are you able to SSH into the PI and leave this command running until you get dropouts: ?

sudo journalctl -f

and paste the output here?

Many thanks Michel, I’ll set that up and then force the problem (by essentially just playing a track) and see what’s printed.

I’ll post the output here when I have something.

Ok, so it seems to me that I’m connected fine, then I play a track and either the spopd (that I keep reading about) falls over and I have connection issues with spotify. (please correct me if I’m wrong)

here is the log output as requested :slight_smile:

Dec 10 16:53:40 volumio volumio[837]: info: STATE SERVICE {“status”:“play”,“position”:0,“seek”:0,“duration”:213000,“samplerate”:“320Kbps”,“bitdepth”:null,“channels”:null,“artist”:“One Night Stand in North Dakota”,“title”:“Heterosexuality is a Construct”,“album”:“Dissatisfactions”}
Dec 10 16:53:40 volumio volumio[837]: info: CURRENT POSITION 0
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820171] CoreStateMachine::syncState stateService play
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820173] CoreStateMachine::syncState currentStatus stop
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820174] CoreStateMachine::pushState
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820176] CoreStateMachine::getState
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820177] CorePlayQueue::getTrack 0
Dec 10 16:53:40 volumio volumio[837]: info: CoreCommandRouter::volumioPushState
Dec 10 16:53:40 volumio volumio[837]: info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820183] interfaceApi::pushState
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820185] InterfaceWebUI::pushState
Dec 10 16:53:40 volumio volumio[837]: info: [1481388820221] ------------------------------ 90ms
Dec 10 16:53:40 volumio volumio[837]: info: FIRST BRANCH
Dec 10 16:53:40 volumio volumio[837]: info: BEFORE: SPOP HAS 1 PROMISE IN STACK
Dec 10 16:53:40 volumio volumio[837]: info: AFTER: SPOP HAS 0 PROMISE IN STACK
Dec 10 16:53:40 volumio volumio[837]: info: Pushing Favourites {“service”:“spop”,“uri”:“spotify:track:3DcTsuUtfdgxiCwQEsU2qE”,“favourite”:false}
Dec 10 16:53:58 volumio volumio[910]: 2016-12-10 16:53:58 [SPTF] 16:53:58.032 E [ap:3953] Connection error: 114
Dec 10 16:53:58 volumio volumio[910]: 2016-12-10 16:53:58 [SPTF] 16:53:58.033 E [file_streamer_simple.cpp:686] handleApErrorCode. Error 101. Timeout: 500
Dec 10 16:53:58 volumio volumio[910]: 2016-12-10 16:53:58 [SPTF] 16:53:58.033 I [ap:1752] Connecting to AP ap.spotify.com:4070
Dec 10 16:54:00 volumio volumio[910]: 2016-12-10 16:54:00 [SPTF] 16:54:00.992 I [ap:1226] Connected to AP: 193.235.232.21:4070
Dec 10 16:54:08 volumio volumio[910]: 2016-12-10 16:54:08 [SPTF] 16:54:08.082 E [ap:3953] Connection error: 116
Dec 10 16:54:08 volumio volumio[910]: 2016-12-10 16:54:08 [SPTF] 16:54:08.083 I [ap:1752] Connecting to AP ap.spotify.com:4070
Dec 10 16:54:13 volumio volumio[910]: 2016-12-10 16:54:13 [SPTF] 16:54:13.083 E [ap:1694] AP Socket Error: Timeout reached (20000)
Dec 10 16:54:13 volumio volumio[910]: 2016-12-10 16:54:13 [SPTF] 16:54:13.084 E [ap:3953] Connection error: 117
Dec 10 16:54:13 volumio volumio[910]: 2016-12-10 16:54:13 [SPTF] 16:54:13.084 I [ap:1752] Connecting to AP ap.spotify.com:443
Dec 10 16:54:18 volumio volumio[910]: 2016-12-10 16:54:18 [SPTF] 16:54:18.085 E [ap:1694] AP Socket Error: Timeout reached (20000)
Dec 10 16:54:18 volumio volumio[910]: 2016-12-10 16:54:18 [SPTF] 16:54:18.086 E [ap:3953] Connection error: 117
Dec 10 16:54:18 volumio volumio[910]: 2016-12-10 16:54:18 [SPTF] 16:54:18.086 I [ap:1752] Connecting to AP ap.spotify.com:80
Dec 10 16:54:23 volumio volumio[910]: 2016-12-10 16:54:23 [SPTF] 16:54:23.087 E [ap:1694] AP Socket Error: Timeout reached (20000)
Dec 10 16:54:23 volumio volumio[910]: 2016-12-10 16:54:23 [SPTF] 16:54:23.088 E [ap:3953] Connection error: 117
Dec 10 16:54:23 volumio volumio[910]: 2016-12-10 16:54:23 [SPTF] 16:54:23.088 I [ap:1752] Connecting to AP ap.spotify.com:4070
Dec 10 16:54:28 volumio volumio[910]: 2016-12-10 16:54:28 [SPTF] 16:54:28.089 E [ap:1694] AP Socket Error: Timeout reached (20000)
Dec 10 16:54:28 volumio volumio[910]: 2016-12-10 16:54:28 [SPTF] 16:54:28.090 E [ap:3953] Connection error: 117
Dec 10 16:54:28 volumio volumio[910]: 2016-12-10 16:54:28 [SPTF] 16:54:28.090 I [ap:1752] Connecting to AP ap.spotify.com:443

You can see, at I asked the track to play at 16:53:40 and my connection is failed at 16:53:58 (connection error 114)

this is always the failure, I have repeated the process many times.

Any help much appreciated as always.

I have exectly the same issue. Last night everything worked. overnight the service was broken.

Dec 18 22:33:48 volumio volumio[3080]: 2016-12-18 22:33:48 [SPTF] 22:33:48.541 E [ap:3953] Connection error: 114

above message appears every time over and over again. Sometimes it will play a couple of seconds of spotify music, but thats all it does.
Webradio works perfectly fine. Network connections are good and spotify works from computer of mobile device perfectly fine.

Something is not working.