Audio broken after installing python on raspberry

Hello everyone,

I’m runing Volumio2 on a PI zero W and I wanted to install this library : to use with a HAT.

So I installed python3 with :

sudo apt install python3 python3-pip python3-setuptools

And then I tried to install my HAT library :

sudo pip3 install unicornhatmini

But after doing this, I can’t play any audio file (from any kind of source : BT, webradio, mp3). Files from the NAS are not visible (even though it’s mounted). I had to do a fresh install from scratch to make it work again.

Here’s the log :

What am I doing wrong ? I’m not an expert but I’m not copy pasting commands without knowing what I’m doing, I just tried to install python :frowning:

Thanks for your help

I figured it out.

It was MPD which was crashing because of missing library !

Thanks to this thread : I managed to solve my issue with

sudo ln -s /opt/vc/lib/  /usr/lib/

Is it supposed to happen ? The only things I installed after fresh flash from last version was :

sudo apt install python python-pip python-setuptools python-dev python-PIL