ASIO format for DSD direct

Volumio Information

Volumio Version: v
Hardware: Awow mini-PC (Intel, 64-bit, 1.5 GHz, 4 GB RAM)
DAC: Chord Qutest

I read that Volumio supports DSD direct. The Qutest DAC supports “ASIO native DSD format”. When I set DSD Direct in Volumio, the Qutest indicates high rate PCM input. It only indicates DSD from Volumio when Volumio is set to DoP. How can I get Volumio to send DSD to the DAC in ASIO format? I need this so I can use higher rate DSD files.
Thanks, Jack

1 Like

Volumio does, but with 2.909 on x86 we are limited by what the old kernel and sound driver supports. Could you do a


from a terminal? (ctrl-F1 to open, ctrl-F2 to get back to the UI).

Also, you could give Volumio beta 3.101 a shot, it has the latest 5.10.y kernel, which supports most DSD direct capable devices. See the Development section, Volumio 3 beta testing for x86.

Is there a 64-bit version of Volumio? I would prefer that, especially based on a later Linux version. I would like that on both the PC and RPi 4, but I would settle for a 64-bit PC verson, when it becomes available.

Could you give me a link? I’m finding the latest beta as 3.083.

look at the last posts :slight_smile: you will find it…

look at my last post in the x86 beta thread. My OP has not been edited yet

we only do 64bit with Volumio 3, based on kernel 5.10.60😀 with regular updates. When a new LTS arrives (5.15.y??), we’ll upgrade.

But we’re slowly going off-topic here…

@jack, please consider doing “lsusb”, it will give us the vendor and product id of the DAC.
This helps checking whether/ how Chord registered this DAC for the audio driver.

The link you gave me was for the RPi version, which I tried. The lsusb shows no info about vendor or product. Volumio recognizes the Qutest DAC, but apparently via some other mechanism. In the web UI, it shows Qutest as the Output Device.
3.101 worked the same on the RPi as volumio 2 does on the PC, i.e. DSD direct does not send a bit-stream to the Qutest in ASIO format. Since then, I found the link for the PC version of 3.101. I will check the same things in that.

I did not give you a link to an RPi version, sorry.
I advised to go to the Developer section, Volumio 3 beta for x86 and then to my last post.
Don’t know where you get RPi from…

lsusb shows you a list of usb devices with vendor and product id in format yyyy:zzzz
From that list we can see which one is the dac with its vid:pid

@gkkpch that would be me he was talking about rpi and pc… (x86) both you could find the same way explained. rpi i put the link in the post.

sorry that i respond on a request of him.

. I would like that on both the PC and RPi 4

would you please stop posting RPi links in an x86 thread, it just confuses people.

RPi and x86 don’t have the same kernel sources, so DSD support in the audio driver will not necessarily be the same. That is why I would like to see the vendor and product id (yyyy:zzzz) from the lsusb output so I can check the driver.

OK. I have 3.101 running on the mini-PC. I verified that it is running kernel 5.10.90. Again, the Qutest shows no info on the lsusb. (I checked it by doing the lsusb with and without the Qutest connected. The missing line has no info about vendor or product.) And according to the Qutest, 3.101 does not send ASIO formatted DSD. The Qutest only sees DSD with DoP. As I said earlier, the Qutest needs ASIO formatted DSD in order to use the higher DSD rates, such as DSD512.
When I set DSD direct in volumio, the Qutest indicates high rate PCM. According to the Qutest manual, it indicates DSD when either DoP or ASIO-formatted DSD is received.

Should I assume that ASIO-formatted DSD is some distance down the road? Any ideas? Suggestions? No. I love my Qutest DAC, so I’m not inclined to replace it.
If the answer is that there is no solution in the near future, then so be it, and thanks for your help!

Why are you not willing to share the WHOLE output of lsusb (not your interpretation of it), how do you think we can help without the info we ask for?

Sorry. I thought you just wanted to see the entry for the Qutest. The lsusb output is:
volumio@volumio:/mnt/NAS$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
Bus 001 Device 004: ID 245f:0815
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
The blank line (after the 0815) is the one for the Qutest.

Bad news I’m afraid.
Neither current RPi kernel (4.29, planned 5.10) nor x86 kernel (5.10) offers DSD direct support for device 245f:0815.
I quickly looked at 5.14 and current developement kernel 5.15-rc2 but nothing shows up there either.
This means with Linux you will only get DSD over PCM (DOP), using ASIO with MS Windows is an other story.

1 Like

I very much appreciate your help with this. There is no way I’m going to use Windows for anything, so I guess I’ll stick with the DSD 256 or slower. I look forward to your upcoming 64-bit releases. Thanks!