Anyone else have luck with Edimax WIFI adapter?

Hi folks, trying to get wifi to work on a Raspberry Pi running Volumio. First I just tried the web interface to enable wifi. No luck. I then installed and tried wicd-curses, but no matter what I do, it hangs on getting ip address, and then nothing. ifconfig shows the interface is up. I’m using WEP, and have tried all of the authentication options. Trying to just use a hex key to keep it simple. These Edimax dongles supposedly have kernel support. Comes right up on a Windows machine, so I know the hardware is good.

Would love to hear what worked for you.

Which model that you used?
I’m using the one listed in the Compatible Wireless Adapter and it works a charm.

Before that I’m using TP-Link which I can’t recalled the model number as I already throw it away; so much pain in the *ss trying to make it work.

I am running an Edimax 7801, no issues. I found out that in some occasions - trying to put to much config changes into one, nervous impatient finger … - the wifi settings do not get stored correctly. I ssh’d into the pi and checked /etc/network/interfaces and found that the config is basically empty. Manual editing works, but also after rebooting, waiting for a couple minutes until everyhing settles and then making the wifi setting the only change it should work as well.

[i][size=85]Hi - I own a RaspPi B+ and want to use Volumio 1.51 with a Edimax EW-7811Un USB Wireless Adapter. I have a hidden essid and WPA security.
I’m not able to get the adapter to work. Message I get is:
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
RTNETLINK answers: File exists
Failed to bring up wlan0.

Any ideas?[/size][/i]

ok - I’ve discovered that when I allow the WiFi-Router to broadcast the ssid WiFi works flawlessly. Strange, but there you go.

I have two Edimax EW-7811Un adapters and editing this file /etc/network/interfaces to include the following code has worked for both.

#use the following for static wireless: auto wlan0 iface wlan0 inet static address 192.168.x.x netmask broadcast gateway 192.168.x.x wpa-ssid "your ssid" wpa-psk "your passkey"Note that this uses a static ip address and wpa for encryption, you may have to adapt it to suite your setup. Obviously replace the x’s with your data.