Always an ALSA-Error after first reboot

He experts, i hope someone can help with the following problem:
I can install Volumio (2.834) on a raspi 2, tested also on raspi 3b.
DAC is Hifiberry DAC2 Pro, choosen as DAC Pro+ in the i2s dropdown-menu.
Everything works fine with a new flashed sd-card.
But if i only make one restart/reboot, i get an ALSA-Error everytime time i start to play music.
The only thing that helps to start Volumio work again is flashing the sd once more and start with this, new flashed sd.
Any idea?
Ist the Hifiberry DAC2 Pro the problem, because it´s not running 100% with the choosen DAC Pro+ driver?
Thanks for any idea or help :+1:!

alsa-fehler-volumio_1053607

It may be the cause. Can you share the content of /boot/config.txt please ?

…and here you are:

initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1

include userconfig.txt

Volumio i2s setting below: do not alter

dtoverlay=hifiberry-dacplus

I have also asked for help at the hifiberry-support and they say, that the driver of DAC plus pro ist 100% identical to DAC2 Pro. So the driver cannot be the problem.

I have a similar issue but my Dac2 Pro has never worked (it’s fine with HiFiBerryOS so I know it’s not hardware).

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/3
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2

volumio@volumio:~$ uname -r
4.19.118-v7+

The overlay is correct in config.txt and I’m also using Dac+ Pro as the DAC model.

Thanks

Gary

In trying to fault find, I set things up as a DAC+ Pro in Volumio, shut it down, removed the overlay line in config.txt, powered back up and I can now see the card: -

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/3
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
card 2: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

If I playback, I get sound from the RCA’s but NOT the headphone socket. This is really annoying as the reason I picked this card was for the headphone socket.

It’s also 100% volume, the volume control in Volumio is still present but it doesn’t matter what you set it to, it makes no difference on the volume.

I went back to HiFiBerry OS and that detects the DAC as a DAC2 Pro in the system information but aplay -l has this: -
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

Volumio is the same: -

card 2: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

HifiBerry has output from both the RCA and headphone socket so my gut feel says the overlay isn’t applying the right settings here.

I’d really like to get this card working on headphone too.
I currently have a trial of Virtuoso and I would really like to hear the Tidal integration before it expires.

@volumio This might be something that needs your assistance with please.

Just a suggestion. Maybe the headphone output has its own volume mixer. Check in Volumio playback if an other volume mixer is available.
Or SSH and check (something like that, I can’t check now)

alsamixer -D hw:2

@balbuze Tried a few things around the mixer but still nothing out of the headphone socket.

I suspect since this DAC is using the DAC+ definition that the kernel being used only has the definition for that board and hasn’t been updated to allow for the headphone socket on the DAC2 Pro.

I’ve asked HifiBerry if they have updated it or plan to update it in any 4.x kernel. It’s clearly been updated in the 5.x kernel as that is what HiFiBerry OS is using.

I am having the same issue, started off with no problems listening to the Radio Paradise plugin, but then after a reboot, no sound at all, same ALSA error as in the OP of this thread.

Multiple reboots, full power cycles, etc… no sound, ALSA error as shown in the OP of this thread. I did notice after some reboots the mixer has reverted to hardware (I had it set for none), and one time “undefined” as well.

Please help as this unit will be a Christmas gift, if only I can get it working, the recipient is not technical.

I am only using the RCA outputs, with a brand new Volumio install, image downloaded this evening, using the HiFiBerry DAC+ Pro driver. RPi 4B 2GB.

Do you use an other plugin such as equalizer?

removing the overlay line in config.txt got it working for me.

I’ve got the same problem on a new install…no joy after hours of attempts.

Removing the overlay line in config.txt did nothing for me. This is getting old.

same here - problem still existing.

Hello everybody, same config, same problems, headphone socket not working and a problem with ALSA.
From what I read it might be an error of the Kernel being too old. The DAC + Pro has no jack output so maybe the problem comes from this but that’s pure speculation from a novice.
@volumio, would you happen to know by any chance if the drivers for the Dac2Pro should be included soon?
Thank you and have a great day!

Edit: No more ALSA error when commenting out the overlay line, however the headphone socket is still offline, it would be awesome to get it working properly.

Edit 2 : Despite the aux output functions there is now no way to change the volume through the browsers (I tried on my phone and one laptop) I don’t know if it’s related to the commenting out of the overlay.

Had the same problem with the Hifiberry DAC2. Hifiberry DAC+ Pro was selected as the sound card setting.

Initially everything runs absolutely fine. But after the first reboot the sound is gone. You can set in the sound card drivers what you want, it remains silencium.

If you remove the overlay in Config.txt as described and reboot, the sound is back. But the volume can no longer be controlled via software. You can also set what you want in the settings for playback volume, it remains the same loud.

It seems that something is wrong in the implementation of Volumio for the Hifiberry card.

Yesterday received a Hifiberry DAC2 Pro. An then to find out it has a problem with Volumio…

Buggers… No working solution at this moment ?

Just for all with this problem - there is a workaround that makes it possible to restart with running Hifiberry-DAC without writing a new image to the sd-card:
Disable I2S DAC in settings (playback options), reboot, activate it again, choose Hifiberry DAC+ Pro again - and it will run again.

Thank you for the reply. I just tried it, but i get the known Alsa error.