alsamixer volume

Hi
I have a RPI 3 + Allo Kali + Allo Piano 2.1

I have just downloaded Volumio 2.31, set output device to Allo Piano 2.1 and Dual Mono and in the volume options I have set Mixer type to None and also noticed that Max volume level is set to 100. I also turned audio sampling on to re-sample to 32/768

Out of interest I activated SSH and had a look at the alsamixer and noticed that the Master Volume was set to 46 (-20.00 db gain), the Digital and Subwoofer settings were also set to 46.

Is this correct as I understood that messing with alsamixer loses bit perfect reproduction (although I know re-sampling also does this). Or is this a Volumio setting?

Cheers

Nick

Theoretically, if you use Alsamixer with hardware Volume, the transmission is still bitperfect, and the DAC uses its internal volume control.
In any case, I don’t see the point of re-sampling to 32/768 : this is the best way to loose bit-perfect, and furthermore the DAC can support only 24/192…
To achieve the best sound possible do this:

  • Enable hardware mixer
  • Set volume to 100 (from now on you can control the volume, some people report best results while at 100, but IMHO you can safely adjust volume without loss)
  • Disable any resampling

many thanks for your reply.

So I will disable re-sampling

Are you saying setting mixer type to Hardware is better than setting it to None?

Cheers
Nick