"ALSA?" issue with Volumio 2.873

Volumio Information:

My Volumio is not working anymore and it displays the error below when trying to play any content:
Failed to open “alsa” [alsa]; Failed to open ALSA device “hw:5,0”: No such file or directory.
My Tidal account seems gone, though I do see my favorites (other than Tidal).
Volumio Version: 2.873 (Beta)
Hardware: RPI4 + WaveIO USB

Check in playback if your Dac is properly configured. Save the configuration and retest.

I don’t know what happened. I tried everything yesterday, and it didn’t budge. Today, I restarted and it came back online, including my Tidal settings and account.
Well, thanks!

Follow up on this.
Though the RPI came back online, I have not been able since to run any streaming for any reasonable amount of time. I’d start streaming a station, and it’d stop within seconds (would play up to a minute) though the Volumio page would say it’s still streaming. Before this started happening, I’d leave it on for days and it would just never stop.
Today I rebuilt Volumio (on the original version that worked well at the beginning - 2.861) but I can’t get it to play for any amount of time.
It’s extremely frustrating and it’s been going on for days now. Any thoughts?

What is the order in which you power your dac and Rpi. Have you tried to unplug and replug once Volumio is up?

Power supply?
DAC power supply?

I typically leave the DAC plugged in all the time (also, the DAC is always on). Which is why, typically, when I restart the RPI, the DAC may output noise for a few seconds (at full volume).
But this has never been an issue until these recent problems started occurring. I never really had to restart the RPI before during a few long weeks of flawless operation.

The DAC is always on, and has always been connected to RPI via USB. In the rare occasions I restarted the RPI the USB would always stay connected and the DAC on.

Can you send a log when the issue occur?


I managed to make it work by rebuilding the microSD card and going back to the original Volumio version (2.861). All other, older issues (random play of another track, removal of duplicate favorites impossible, etc.) are back, but at least I can play tracks and radio stations.