[almost Solved] Samba folders from Windows 10 not working

I solved this one while writing this very same post, so I’m sharing the solution with you, in case someone has the same problem.

I have a working Volumio ver.2.522 system running on a Raspberry Pi2, but I couldn’t find a way to access the shared Samba folders from a Win10 host on the same lan.

Initial scenario
I couldn’t access Volumio’s folder from the Win10 machine.
Windows would “see” the Volumio host:
02.jpg
but couldn’t access it:
03.jpg

The Solution
Enable “insecure guest logins” in Local Group Policy Editor (run gpedit.msc with admin user on Win10):
Computer configuration\administrative templates\network\Lanman Workstation: “Enable insecure guest logons”

Reference: https://serverfault.com/questions/895570/how-to-configure-samba-to-work-with-windows-10-1709

p.s. update
I guess It’s not the solution after all :frowning:

I can indeed access the folder now but only partially :frowning:
There’s a permission problem that it doesn’t look obvious to me. Let’s just say I can create folders but not save any file inside :frowning: Win10 users can browse the whole INTERNAL are still limited whene writing stuff. I will post further development whenever I wrap my head around it and find a better approach.

I’m open to suggesstions.

I think I’ve come a final solution but I’d really appreciate if some of you Linux “experts” would comment on it since I’m not that much into securing Linux systems.

In order to be able to copy files+dirs from Windows to Volumio /data/INTERNAL folder through Samba I had to add these four lines to /etc/smb.conf , forcing the user/group to be volumio/volumio and permissions to be 0777:

[Internal Storage] comment = Volumio Internal Music Folder path = /data/INTERNAL read only = no guest ok = yes force user = volumio force group = volumio force create mode = 0777 force directory mode = 0777

Now everything is being written inside /data/INTERNAL the same way I see files/folders are set inside /mnt/USB/ per default. So I guess it’s acceptable.

I guess the problem initially arised because of some latest Win10 updates that change its behaviour.
Alais, I hope I didn’t brake anything special by doing so. Please let me know if this approach has security risks/flaws/inconsistencies that I should consider.

It works for me!
I see all the folders.
Thanks