Allo BOSS does not work as master


I can’t manage to get Allo BOSS work as master, it always works as slave. From DAC list I select Allo BOSS. In config.txt I see “dtoverlay=allo-boss-dac-pcm512x-audio”, but Allo BOSS works as slave. Are some additional changes needed?

Volumio Information

Volumio Version: 2.873
Hardware: RPI3

How do you know it works in slave mode?

Thank you for reply.

  1. pcm5122 does not generate BCLK and LR signals, but RPI does generate them. But it should be vice versa.
  2. By means of logic analyzer I see that RPI does not try configuring pcm5122 as master (does not configure PLL, BCLK and LR as outputs and so on), instead RPI sets pcm5122’s PLL source to BCLK.

That’s a very interesting observation, thank you very much!
This means that the Allo BOSS sounds even better with the correct configuration. :grin:


That’s indeed strange.

Yes, it is strange. I must have missed something I cannot find out.

Hello Michelangelo
If this is actually the case, is it possible that you include the correct configuration of Allo BOSS with the next update?


I modified the line in /boot/config.txt to look like this:

dtoverlay = allo-boss-dac-pcm512x-audio, slave

it is right?

Slave is not right
The documentation from Allo says it has to read:

“dtoverlay = allo-boss-dac-pcm512x-audio, 24db_digital_gain”

I would recommend to ask Allo…

I have just read that this parameter can lead to overloading … This is not optimal and can be dangerous!

I recommend not to use the parameter “dtoverlay = allo-boss-dac-pcm512x-audio, 24db_digital_gain”!

The parameter in Volumio seems to be correct.

The answer from Allo resulted in the following: the BOSS Dac works in master mode as it should.

By default it will configure in master mode only, if any one wants to work in slave mode, then only need to force by adding dtoverlay with slave.

In your unit it is not working as master mode?

Can you please login to volumio through ssh and share below command result

aplay -l (Lower case of L)