Album cover art

I have cover art stored with each album but there seems to be no option in V2 for displaying it. Am I missing something?



I installed the cover image inside the flac folder on my local rpi usb stick. name of the cover image: cover.jpg
works great!


I have cover.jpg in every album folder on my NAS but only the generic artwork shows.

the covers works local?

By generic cover I mean the patchwork image, which I assume is the default. None of the images from the NAS album folders show.

how are named album art on your folder ?

The cover images are all cover.jpg


I think I understood what goes wrong. Thanks for reporting

Is there any solution to this in the pipeline?

Yes is on the bugs we need to fix before releasing another version

Hi there,

i have the same Problem, but ironically i have an album on my NAS where´s no “Cover.jpg” inside the Album folder, but the album cover is shown! :open_mouth: ???
On the Raspi 3 is the newest Version 0.994 from 09/29 of Volumio 2.

Have i understood it right? I have put the cover with the name “Cover.jpg” in the corresponding folder. The resolution is 600x600 pixel with 200dpi.
Which resolution is recommended? Scales Volumio, or respectively there is a limit of resolution?

Thank you for your answers…

EDIT: I have to enclose my question…
normaly i choose my Albums over the Point “Music Libary” and there are no Covers.
Now i´ve tried the Points Artists, Albums, Genres and if i choose an Album from one of theese, the Covers are displayed at “Playback”.
Why not at the Music Libary?

Hi Jens,
basically if Volumio finds a coverart inside the folder, it shows it. If not it looks for it on internet

Hi Michelangelo,

do you have seen my edit? I think the posts have overlapped. :unamused:

We’re fixing that. Also, I don’t think we’re ever going to show it on the music library, as browsing will be quite slower… If we find a good way to retrieve those data in a fast way, we’lldo it…

Thank´s for your answer. It´s not a big problem for me, if this not works. I´m old-fashioned and i rather choose and browse my music over the Music Libary. :slight_smile:

Thank you for your effort

Hello again,

i thought about your answer and in principle I understood it.

But one thing confuses me. Why ist there one Album in my FLAC Folder witch shows me the cover on the Playback site and that regardless of the fact, that i choose it over the “Music Libary” ? Until now I have only one FLAC album found in which it is so.

I have no “Cover.jpg” Picture in the Album folder, i have ripped the CD with the same Program and settings like the others. As well i used the Programm mp3tag for all CD´s.

The inability of Volumio to use the local cover.jpg image does not appear to have been fixed in the latest (November) release v 2.031.

Also, some of my albums which have the correct album art embedded show entirely different covers in Volumio. Where is Volumio getting this from? It is incorrect. It should not choose cover art without seeking confirmation, and it’s clearly doing this. (example: Charles Dutoit, Montreal Symphony, Decca recording of Holst’s The Planets (1987), from CD, correct cover embedded, is shown correctly by my Auralic Aries Mini streamer. The identical album, on a different network drive connected to the RPI/Hifiberry DAC+Pro running Volumio, shows in Volumio as the DGG Von Karajan recording. It would be better to show the generic art than the wrong art. Some of the identifications are downright bizarre. See example image. Can this be fixed, please?
Screen Shot 2016-12-03 at 10.09.29 PM.png


That was quite a bit to read, but it didn’t help with getting the wrong album cover. It looks like different parts of the program cache different images. With the correct cover.jpg file in place , and when I have played the first track in the offending album, the main screen shows the correct art, but if I browse by artist or album, the incorrect web image still shows. Where are these things cached and can I access the caches via SSH?

Pls, read, you will find the reply to your question, that’s why I liked it (sorry but I can’t repeat the same thing lot of times)