Album Art - What's going on???

Hi all, I wonder if anyone can shed some light on an issue that’s driving me crazy. See attached image - I am having issues with Volumio not correctly handling album art. I can’t quite figure out what is going on. After I initially copied my music files onto the hard drive I am using attached directly to my RPi via usb, I saw the album art was not ‘correct’ even after a rescan/rebuild. So I connected the drive to my MacBook and fired up Kid3 (mp3 metadata batch editing software) and spent what seemed like forever sorting it all out - every single album was correctly labelled, every single compilation album was given the ‘various’ album artist tag (so the albums weren’t split up into hundreds of separate albums!) and then I went through everything again and embedded the correct album art through various means - ie Google image search, Amazon searches etc. The pictures used were all jpegs, all resized to 500 x500.

After re-attaching the drive to the RPi and carrying out a rescan I saw that all the compilation albums were correctly sorted but I am still having massive problems with the album art. Why is Volumio showing a Darren Hayes album cover on an INXS greatest hits album? The files all have the correct image embedded, all the tracks have the correct titles, file names etc. Why is Volumio overriding that information and doing something else completely random? None of these albums have ever had the ‘wrong’ album art embedded - in the example above the files have always had the correct picture embedded. The examples in the attached picture is just the tip of the iceberg, there are plenty of others that have completely unrelated album art showing up for no apparent reason. I’ve tried resetting the image cache. I have some other albums - for instance the Stranger Things OST albums all of which have the right embedded album art, also the soundtrack for Interstellar by Hans Zimmer for instance, but they’re not showing any album art in Volumio - no idea why, other albums that have exactly the same format image, same size etc, all embedded the same way, and they show correctly, but there’s absolutely no difference between them. I know they have the correct image as I tracked them down and embedded them individually, as per all the other albums. There are dozens of albums with incorrect album art showing. Whilst in Kid3 I removed any weird tags (iTunes embeds its own weird spurious crap for instance - all removed manually in Kid3) to make sure things were not getting confused by them but it’s still not sorted out.

Apologies if I’m rambling a bit, it’s just driving me nuts and I’ve exhausted all the solutions I could think of… As ever I am very grateful for any help offered.

Regards
Ste
Screenshot (9).jpg

1 Like

Hi !

I have almost the identical problem with missing Album art. In the album section there is A LOT of blank art, this after i updated to 2.698 (not sure on what verion i was prior to this mishap). I use a Pi3B with local 4Tb storage via USB, with previous versions of Volumio i NEVER had an issue with the Album art. I have ALL my flac’s with correct ID3 tags (im a bit of a stickler with that) & all albums are in seperate folders.

I have reverted to previous versions (mounted on fresh Etched TF cards) to no avail, im stumped now, not sure what is going on.

I just hope a future version will correct this :confused:

Hi, for performance optimization we don’t read the stored albumarts in id3 tags.
Your best bet to have good arts is to place the image folder.jpg (or .png) in the album folder :wink:

Then, go to sources, clean albumart cache et voilà

Well, that is very disappointing to find out about this after purchasing the volumio primo. My entire library (100,000+) tracks has all been filed and tagged with the artwork added to the ID3 tags. Now I’m expected to add jpg to the 10,382 albums I have in my library??? This makes me an extremely unhappy customer.

No, you don’t have to do that manually, i have 3400 albums and i was done in 5 minutes with the prog Mp3tag.
Batch extraction of the albumart was easy and it works great. I have all art correct again, thanks for heading me in the right direction :smiley:

https://www.youtube.com/watch?v=ZMC107e1gsM

Thanks for the suggestion, Nemo. I will give it a try.

1 Like

You can also have a look at this post I wrote:
volumio.org/get-perfectly-organ … n-gravell/

Let me know if we can help more

Thanks. The solution by Nemo is working for me. It is such a relief that I do not have to manually add cover art jpg.

Great to hear!

PS: Woul you mind editing your review after your issue is solved?

Yes, I will edit the review, but I can’t figure out how to do it. Can you give instructions on how it can be edited or deleted and then I can write a new review?

I can delete it for you, after that you can write a new one :wink: