Airplay > Volumio > USB sounds badly distorted/resampled :(


I just started using Volumio today, and am on the latest build.

I’m using a Native Instruments Audio2DJ as my soundcard which I’ve previously had success when Airplaying to Shairport from a Mac or iPhone.

Output is working through the onboard soundcard, and I’m able to play a WAV file using aplay through the Audio2DJ from the command line, but when I Airplay to Volumio the music is coming through but horribly distorted and with a kind of static ‘resampled’ effect, almost like it’s down at 4khz or something.

I’ve tried all combinations of resampling, gone through all the kernel types and also deleted the ‘sync’ option from /etc/usbmount/usbmount.conf

Output of cat /proc/asound/card0/pcm0p/sub0/info is:

card: 0 device: 0 subdevice: 0 stream: PLAYBACK id: Audio 2 DJ name: Audio 2 DJ subname: subdevice #0 class: 0 subclass: 0 subdevices_count: 2 subdevices_avail: 1


access: RW_INTERLEAVED format: S24_3BE subformat: STD channels: 2 rate: 44100 (44100/1) period_size: 64 buffer_size: 21845


[code]state: RUNNING
owner_pid : 3690
trigger_time: 2876.821963104
tstamp : 3014.792426250
delay : 21675
avail : 170
avail_max : 960

hw_ptr : 6084990
appl_ptr : 6106665[/code]

Any suggestions?

UPDATE - just confirmed webradio plays fine so the problem seems to be confined to Shairport…

I am having the static/crackling problem with Airplay/Shairport on Volumio Beta 1.4. I have the first Model B Raspberry Pi (256 MB RAM) and a (very cheap) Daffodil US01 USB Sound Card 7.1 Channel dac USB sound card. Shairport only is affected; MPD is crystal clear. I reverted to Volumio Beta 1.3, which doesn’t have any distortion for me.

Had the same issue, changed the device option to the driver of my USB DAC in /var/www/command/player_wrk.php (took me some time to find out where shairport was started :frowning:
See my post in

changed line at /var/www/command/player_wrk.php

$cmd = '/usr/local/bin/shairport -a "Volumio" -w -B "mpc stop" -o alsa -- -d default > /dev/null 2>&1 &';

works fine for me :slight_smile:

I have a USB DAC and I need to force USB 1.1 in order to get the sound not to sound distorted/static-y. Just add the following to /boot/cmdline.txt:


For more info see