Airplay problems 1.55

Ever since IOS 9 has released, shairport and airplay have been really buggy. I have tried multiple raspberry pi’s with multiple sd cards and multiple airplay source but I get the same result each time. Starting a song is fine, but as soon as you switch songs the connection drops. The airplay connection will also drops if you try to skim a song. I have heard that shairport-sync is a bit more stable and I saw a post that it was integrated into volumio 2, but I have tried volumio 2 and couldn’t get it working. Any thoughts on issues, or integrating shairport -sync with the next update?

I am experiencing the same problem Raspberry 2B, Volumio 1.55 and iOS 9.2. for me the error is not consistent, sometimes I can skip songs sometimes its one song and done. I also noticed a difference between streaming music and music loaded on my phone. If I SSH in can I call to stop the shairport and run it again while I watch the output of the program?

Not sure about stopping it. I think the issue is shairport is no longer supported but shairport-sync works great. I read in a forum that volumio 2 uses shairport-sync but I downloaded the beta and had no luck at all. I think that issue was more with the USB DAC though.

I’m experiencing the same problems when using iOS 9.2.1.

Definitely seems to be that shairport by itself is no longer supported, glad to see I am not the only one with this issue. It looks like the easiest way to resolve the issue is swap change shairport with shairport-sync. Last night I tried turning off airplay on volumio and installing shairport-sync just on jessie, but couldn’t get it to work. Even if I could, I wouldn’t know where to begin to integrate it with the UI. Someone did this with RuneAudio and had promising results but the tutorial is written for Arch. Looking at MoodeAudio, it seems they recently adopted shairport-sync with their latest update but I have not tested the image yet. I was able to get it working with volumio 2 using the HDMI out since it seems volumio 2 is using shairport-sync, but the problem is I have a USB dac and the UI isn’t built for that yet, and getting a usb dac to work with Rasbian Jessie just seems to be a bear of a project with no decent tutorials written yet.

I installed Volumio 2 and did some manual configuration, as described here:, to get my HifiBerry Digi+ to work (it uses i2s) and now I have Airplay functionality again! I occasionally get some audio dropouts, especially in the beginning of songs but I can live with it for now.

Since I only need aiprlay functionality for this project, I ended up installing shairport-sync directly from Mike Brady’s github ( following his instructions and it works great. Currently using a pi0 with USB sound card. I know there is some question with volumio 2 meeting the Pi0’s ram capabilities so I guess we will see what happens. When Volumio2 is official released, I may revisit this for more features.

I’ve installed volumio 1.55 and 2 on a raspberry pi and both times had issues with airplay over wifi. My solution is to just run it wired but maybe this helps? Anyone else only having issues while over wifi?

Hi All,

One more ! I’m experiencing the same issue with Volume 1.55.
I’ve my own idea here which might be linked to the wifi and how it works.
When I use the Raspberry Pi 2 B+ over wifi my SSH connection drop a lot.
With Airplay, it is fine as soon as I don’t change the album or the playlist by myself otherwise I lose the airplay and all services such as -web- the local volumio homepage. For example I’m not able to open my local volumio homepage, I need to wait a couple of minutes. Once the local website is back I can find volumio as a airplay source.

On the other hand, the ethernet connection seems to be very strong without drop, connection lost.

I’ve tested volumio 2 but I hope to see some improvement :slight_smile:
Good luck the team ! :mrgreen:

Quick news, by using another USB WiFi Adapter my main problem practically disappeared.
Never underestimate the quality of your USB Wifi adapter ! :slight_smile:

I don’t think this issue is specific to Volumio. Airplay is painful even on official apple gear and seems to be quite pedantic about the network. Running wired makes things operate best, but there are some tweaks to access points you can make that allow the specific type of traffic to flow more easily. I’d suspect it’s more about that and about new issues with upgrades of Mac OS X and it’s particular version quirks.

You want to try running a wireless bridge, it aint like it should be…