Airplay not autostarting after upgrading to 2.692

Airplay was working without any problems, but after upgrading to 2.692 from 2.673 using the web interface I lost it. It seems that the upgrade stopped airplay service from starting after boot, as ps aux | grep airport returns nothing and executing shairport-sync & fixes the problem.

I could not find any logs:

$ systemctl status shairport-sync --full
● shairport-sync.service - Shairport Sync - AirPlay Audio Receiver
   Loaded: loaded (/lib/systemd/system/shairport-sync.service; static)
   Active: failed (Result: exit-code) since Sun 2019-12-22 07:56:55 UTC; 6min ago
  Process: 1365 ExecStart=/usr/local/bin/shairport-sync --configfile=/tmp/shairport-sync.conf (code=exited, status=217/USER)
 Main PID: 1365 (code=exited, status=217/USER)

Dec 22 07:56:55 my-volumio systemd[1]: Starting Shairport Sync - AirPlay Audio Receiver...
Dec 22 07:56:55 my-volumio systemd[1]: Started Shairport Sync - AirPlay Audio Receiver.
Dec 22 07:56:55 my-volumio systemd[1]: shairport-sync.service: main process exited, code=exited, status=217/USER
Dec 22 07:56:55 my-volumio systemd[1]: Unit shairport-sync.service entered failed state.

$ journalctl -u shairport-sync.service 
No journal files were found.

Seems to be the same problem as reported in Shairport fail, Volumio 2.163, RSP2, HifiberryDIGI+ from May 2017 (???).

Confirmed on my test system. Toggling from the Sources menu doesn’t have any affect. The active/inactive status will toggle red but the status never truly changes.

I confirm the same behavior here… and the same fix as described above…

Did anyone experience the same behavior? Did anyone find a workaround, except starting shairport manually?

I have still been having no success playing music via Airplay, even after a few upgrade versions of Volumio. I tried toggling the switch under settings on and off, restarting my Raspberry pi, and nothing worked, except logging in via SSH and manually doing the shairport-sync & command mentioned above. When I restart the system, I need to run that command again, each time.

Hi. I had the same problem. I am currently running 2.703 Here is how I solved it:

  • Install supervisord which will restart a process if it fails
  • modify a few config files
  • Reboot

I have no idea how well this will persist after an upgrade, but this will not be hard to re-do if needed. Here are the actual commands and config file edits:

  1. Login via ssh to the volumio account on your local volumio device. I am using a raspberry pi
  2. sudo su -
  3. apt install supervisor
  4. Create /etc/supervisor/conf.d/shairport-sync I used pico for this Here is mine:

To create, copy the two lines above into /etc/supervisor/conf.d/shairport-sync.conf
pico /etc/supervisor/conf.d/shairport-sync.conf [/code]
5. Modify /etc/supervisor/supervisor.conf    Here are the parts to change:
logfile=/var/log/supervisord.log ; (main log file;default $CWD/supervisord.log)
pidfile=/var/run/ ; (supervisord pidfile;default
childlogdir=/var/log            ; ('AUTO' child log dir, default $TEMP)
  1. Reboot and it shairport-sync should be running after being started by supervisor. If it fails for some reason, here are a few things to look at:
  • Run systemctl -l status supervisor.service It should point you to the issue
  • Run systemctl start supervisor.service In case it did not start on boot. The package I installed setup the systemd config files so it should be trying to start already and this should not be needed.
  • Check the log files in /var/log/ You’ll see one for supervisor itself and both stderr and stdout for the shairport-sync service, in case they log anything.

I am really not sure why this work around is needed. Is airplay now a licensed feature or part of myvolumio integration somehow? I haven’t looked into that. I have been using volumio for years and did not need any of the integration of with services other than spotify, but sometimes I like to use airplay to play from a podcast or the spotify app itself.

The issue seems to be solved in version 2.729.

Thanks to all posting here.

Glad to hear it! Not for me, I’ve upgraded to 2.729 and just today to 2.773, but there’s been no change for Airplay to work for me without manually starting it through the terminal.

I guess I need to investigate easy ways to save my settings and restart my Volumio setup on my Raspberry Pi to see if a fresh start fixes it.

Which plugins you have installed? (meaning, all plugins you ever installed on this system, even the ones you removed now).
Also,did you install things manually?

We are trying to understand where this issue comes from and it seems that a particular part of the system gets overwritten in some circumstances and this results in airplay not working…

Here’s what shows up under my plugins:
System Information 0.1.0
LastFM Scrobbler 1.1.12
Spotify 1.3.5
Backup & Restore Data 0.7.2

I’m pretty sure I installed them all through the Settings/Plugin Manager, and I don’t think I’ve installed any other ones.

I installed Volumio on a fresh Raspberry Pi 3 B+ with Allo BOSS in February 2019 and Airplay/etc worked for several months. I’m not sure what happened to it.

Are you able to use SSH and launch some commands if I ask to?

Sure, I’m not an expert, but I can handle that. Eager to help; thank you!

Thanks so much. Please, login with ssh then launch those commands:

/bin/mkdir /mnt/overlay
/usr/bin/sudo /bin/mount /dev/mmcblk0p3 /mnt/overlay

Then, paste this, and copy and paste the output here (this is the value that we need)

cat /mnt/overlay/dyn/etc/passwd

Once done, you can do (to revert the changes)

/usr/bin/sudo /bin/umount /mnt/overlay
/bin/rm -rf /mnt/overlay


I did that stuff and this is what I get:

root:x:0:0:root:/root:/bin/bash daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin bin:x:2:2:bin:/bin:/usr/sbin/nologin sys:x:3:3:sys:/dev:/usr/sbin/nologin sync:x:4:65534:sync:/bin:/bin/sync games:x:5:60:games:/usr/games:/usr/sbin/nologin man:x:6:12:man:/var/cache/man:/usr/sbin/nologin lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin mail:x:8:8:mail:/var/mail:/usr/sbin/nologin news:x:9:9:news:/var/spool/news:/usr/sbin/nologin uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin proxy:x:13:13:proxy:/bin:/usr/sbin/nologin www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin backup:x:34:34:backup:/var/backups:/usr/sbin/nologin list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin ntp:x:100:104::/home/ntp:/bin/false dnsmasq:x:101:65534:dnsmasq,,,:/var/lib/misc:/bin/false messagebus:x:102:105::/var/run/dbus:/bin/false statd:x:103:65534::/var/lib/nfs:/bin/false avahi:x:104:106:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false sshd:x:105:65534::/var/run/sshd:/usr/sbin/nologin systemd-timesync:x:106:109:systemd Time Synchronization,,,:/run/systemd:/bin/false systemd-network:x:107:110:systemd Network Management,,,:/run/systemd/netif:/bin/false systemd-resolve:x:108:111:systemd Resolver,,,:/run/systemd/resolve:/bin/false systemd-bus-proxy:x:109:112:systemd Bus Proxy,,,:/run/systemd:/bin/false mpd:x:110:29::/var/lib/mpd:/bin/false volumio:x:1000:1000:volumio:/home/volumio:/bin/bash upmpdcli:x:111:65534::/nonexistent:/bin/false Debian-exim:x:112:116::/var/spool/exim4:/bin/false

Thanks! Now we know what went wrong.

The solution to make shairport work again, for people interested is this:

Login with ssh then launch those commands:

/bin/mkdir /mnt/overlay
/usr/bin/sudo /bin/mount /dev/mmcblk0p3 /mnt/overlay
sudo rm /mnt/overlay/dyn/etc/passwd
/usr/bin/sudo /bin/umount /mnt/overlay
/bin/rm -rf /mnt/overlay

Reboot and it will work

Thank you for your help! Unfortunately, this didn’t seem to have any effect for me. I ran those commands, rebooted, and didn’t notice any change.

I toggled the Shairport-Sync switch under settings and that also didn’t do anything.

Hopefully my issues are over; I used the Factory Reset button and re-did everything. I didn’t restore settings, I entered things as new. And Airplay is working, even after a reboot.

I am running v 2.773 on a pi 4

Airplay starts fine the first time the system boots. once I connect to airplay, if I disconnect from it my volumio pi disappears as an airplay destination from all devices. also if instead of airplay I choose local or network sources for playback, my volumio pi will disappear as an airplay destination after roughly 30 minutes. the only way I have found to get it to come back is to restart the pi. restarting shairport-sync does not bring it back, neither does restarting networking, neither using the GUI nor SSH works. very strange, it’s as if it goes into some kind of permanent hibernation mode