AirFoil Support

It’s the same situation as before with RaspyFi

AirFoil gives an error:
“Could not parse response from remote speaker”

Please include the following information when contacting Rogue Amoeba Support.

Domain: SSAirfoilErrorDomain

Code: -1500

NSLocalizedDescription: RTSP Protocol Error

NSLocalizedRecoverySuggestion: Could not parse response from remote speaker

SSHTTPStatusCodeKey: -1

SSRTSPRequest: ANNOUNCE rtsp:// RTSP/1.0
Active-Remote: 1916803347
Client-Instance: 383FC9DC37822E2E
Client-instance-identifier: 3D69DB26-A88C-4C28-820A-1ECD4C31A3F9
Content-Type: application/sdp
CSeq: 1
Content-Length: 574
User-Agent: Airfoil/4.8.2 (Macintosh; N; Intel)
Client-computer-name: Adam’s MacBook Pro
DACP-ID: 3CF5696904FB6040

o=iTunes 3470050232 0 IN IP4
c=IN IP4
t=0 0
m=audio 0 RTP/AVP 96
a=rtpmap:96 AppleLossless
a=fmtp:96 352 0 16 40 10 14 2 255 0 0 44100

SSRTSPResponse: Apple-Response: iWfnZR3ChkzN5l11ouPwYEokq8+ubf4U2Ij41ZQhqBVDi1+XDPgzFI1EtgSI+q57fuPT2nmFEL8ER2bACrfub1KdMPWgStnjAqkwgi5TZGEIQtEqyxvuq+hVWSt/8/qEfoj2BJm79/c+10KYDdxIa2R2/SqVH0lINKaLfAcF9tmREvVUkMX9Ktx5KE2yKd7YkclR6VRtYjUB5NqHv0oyFDbg74AzdOCKo/0bssyUwf2iTH7TuJ1a+wk5Jq/05fsYb38Gk9saS4VGQQ/PTIPc5dZMMW5FHGK9rzOMyWFtgap+QcPhS1e3Es9MmjmhKIcEl2rsaIj3nOuEJx4yUg12IQ
CSeq: 1
Audio-Jack-Status: connected; type=analog

+1 for fixing this.
some day.

This issue comes from Shairport, the AirPort daemon.
It’s been fixed in the latest release of Shairport : … e85e2b4af7

You can easily install the new version :

  1. Install the required packets to compile it
pi@volumio:~/$ sudo apt-get install libssl-dev libavahi-client-dev libasound2-dev build-essential
  1. download the latest sources
pi@volumio:~/$ wget
  1. unzip
pi@volumio:~/$ unzip && cd shairport-master
  1. compile

pi@volumio:~/shairport-master$ ./configure pi@volumio:~/shairport-master$ make
5) test run :

pi@volumio:~/shairport-master$ ./shairport -a Volumio
  1. If everything is working, backup the old binary and replace it with the new one:

pi@volumio:~/shairport-master$ sudo service shairport stop pi@volumio:~/shairport-master$ sudo mv /usr/local/bin/shairport /usr/local/bin/shairport.old pi@volumio:~/shairport-master$ sudo cp shairport /usr/local/bin/ pi@volumio:~/shairport-master$ sudo service shairport start

To the Volumio Team : great work, guys !!

I was trying to implement this shairport update. Got to the test run and get this:

root@volumio:~/shairport-master# ./shairport -a volumio FATAL: could not bind any listen sockets! Shutting down...

Solved it after two issues, adding root to audio group per instructions here:

Still same error though. Then stopped shairport and all was good.

sudo service shairport stop