After Update to v2.657, no volume control

With Rpi 3B+ & Hifiberry DAC

a Factory Reset (back to 2.57x in my case),
configuration with software mixer,
update to 2.668

solved the issue: Volume control is working again.


Same problem, with rasperry pi 3 an hifiberry amp. I tried also to desactivate volumio simple Equalizer 0.4.1 and played with volume configuration (SW, HW,…no other possibility).
Sometimes it seems that config mode does not accept properly the choice of hifiberry am DAQ.

ingohz, you’re a genius. This worked for me too. Shoulda thought of that myself!


Hello, I have the same problem since I updated the Volumio version to 2.668 yesterday. As guys bedore me mentioned I dont have access to Hardware mixer. If I move the sound bar nothing changes. When I reset sometimes I don’t see “software” but only undefined…

since I am not really knowledgeable with programming and coding, can you please advise how to mitigate this issue without going into programming? Is reset to factory settings the only option? …and loosing the settings…
Screens below

Thank you


updated to version 2.692 yesterday and I think the Hardware Mixer is still wired. After the update I got no sound from my IQaudIO DAC Plus (Raspberry Pi 3B) and adjusting the volume had no effect. Read this thread then and decided to make a complete new install on a new SD-card. Now I get sound on my IQaudIO and the Hardware Mixer is selected. If I get into “Options|Playback Options” and open the Mixer selection only the Mixer Types “Software” and “None” are available (see screenshots). Selecting one of these and saving the changes results in a malfunctioning mixer and the sound of silence. I can get out of this only by selecting and saving another output device and enabling the IQaudIO again.

Is that a bug in the Playback Options or am I doing something wrong?

Screenshot_2019-12-20 Volumio - Audiophile Music Player.png
Screenshot_2019-12-20 Volumio - Audiophile Music Player(1).png

Hi everybody

Same problem here. I have an IQaudiO Pi-DigiAmp+. I did a fresh install with version 2.692. I can’t select the digital mixer. It shows Digital, but only Software and None is selectable. If I select the mixer field its just empty.

I would really appreciate any help. I bought my dad a pi 4. It is part of a Christmas present.

Screen Shot 2019-12-22 at 17.43.28.png

I can confirm this: upgraded to 2.692.
IQAudio Dac+ with RPI3B.
Volume very low. On UI changes are shown but volume does not change.
Did a factory reset : same problem and also trouble with mixer options: same as in previous post.
Did a clean install of 2.692 : same problem and idem for mixer options.
Then installed 2.668 (dated november 14 2019), the version that was running before upgrade and now it is OK again.

Same issue here with RPI3B Hifiberry DAC+ volumio v2.692

Same issue here. I’ve updated my both volumios to 2.692 yesterday and both lost volume control. One is with AMP2 and one with DAC+, both on Pi3.

Same problem here with rp3b+ with amp2 and touch 7" after update to 2.692.
Clean install doesn’t help.
Plugins: GPIO Control, NanoSoundCD, YouTube, Autostart

And: NanoSoundCD plugin no longer runs !! :frowning:

Christmas gift for my daughter…

About 100 hours of work with the speakers.

Greetings from Germany

same problem here, with hifi berry dac+.
it can be fixed by clicking the “save” button in the output device dialogue without changing anything.
after doing so, the digital mixer control is responsive again and also selected correctly in the drop down menu.
after a restart, its broken again though…

same problem here,
with RB PI 3 B+, with hifiberry dac plus pro.
I solved with factory reset,
but now I am on 2.673, and I am worried that
updating will mess hardware volume again,
I will not update until this will be fixed

i have the same with 2.692 version, but the volume is more silent than before with the same percentage. Do you experience the same?
I use the Justboom AMP hat with rpi 3b.

I tried to go back to previous versions, but with olderversions i have the problem that spotify plugin doesn’t work anymore (the authentication works but not the validation to link)

i tried the same with RPI3B with justboom hat but can’t get spotify plugin working for that older version. I guess mismatch between volumio version and spotify plugin version ? Did you test this?


Same problem after update to version 2.692 :confused:
This Problem, i have also after update to v.2.657

regards, azoui

Raspberry Pi 3 Model B Rev 1.2
HifiBerry AMP+

Same problem, with RB PI 3 B+, with hifiberry dac plus pro.

I’m hoping for a fix before I do anything like a reset, I can manage for a while with just the volume from my receiver.

updated to 2.692 - posting just to confirm that HiFiBerry DAC+ and Digi on Raspberry 3b+ do not work any more.

The “patch” : “sudo apt-get install libasound2-plugins” worked on one DAC+ device / probably in connection with the other suggestion = save device and hardware control shows up again - on the other devices it does not work, there is not volume control and basically also no sound - after the startup sound which still works.

Another thing: also shairport disappeared - the volumios do not show up any more for Apple play
Streaming from android works - to the one device which was “treated” as mentioned above - as said airplay does not show up

Thanks for looking into this! And MANY THANKS for driving this project, investing time and make Volumio happen!

Same to me.

PI 4 B and HifiBerry DAC+. Most important to me is a running equalizer plugin from balbuze (alsa is not really satisfying). Since update to 2.692 (and factory reset to 2.599 because not working at all) i’am not able to get the equalizer pluginb back to life.

Plainly change (inspite of reset) is the fact that /etc/mpd.conf and /etc/asound.conf is replaced every time after restart. With that the equalizer can’t work any more.

Looking forward to getting the next update (asap).

How cool is this, nice work Martin !!!
for the issue, i also updated in github :

Have the same problem with only Dion-Audio Amp hat and 2.695 version.

With alsa mixer I can regulate the volume.