Adding Tidal Connect

Hi,

I’m facing the same issue on v 2.907 on my futro:

http://logs.volumio.org/volumio/ZbXjA4s.html

No issues with volumio tidal integration, it happens only with tidal connect.

When it happens i need to skip the track that is currently stuck.

as per volumio web interface, the next song seems properly retrieved but the seek is already at its end ( sometimes at half )

Please let me know If any further detail is required

Thanks

Luca

Edit: screenshots link

I think it happens when the sound quality changes.

Was TC with Pi zero ever resolved? It’s not working for me.

There is a new version of tidal connect released in volumio 2.909. This should fix the crash some people were having on sample rate changes on certain devices.

If you were encountering these issues, please update to volumio 2.909 and let us know if it solved your issue.

Hi Mervinio,

Unluckily still facing the issue on v 2.909 ( x86 - Futro S900 )

i just replicated it and extracted fresh logs:
http://logs.volumio.org/volumio/GeLwOeg.html ( time stamp: 7:10 PM - 7:20 PM CEST 14/09/21 ).

Here a video: https://photos.app.goo.gl/givRLbTWKb1PS3XN6

When the MQA song by CSI ends, the player tries to play the “next song” but the seek is already started.

The Tidal app seems stuck: https://photos.app.goo.gl/rVWLRFjtwux25GGA7

If i press the “next” button and then the “back” back one, the track would be properly played but the playlist stops again when the track quality changes ( MQA → NO MQA o viceversa)

DAC: SMSL SU-9.

Please let me know if i can help with any additional info / data.

Really thanks for your efforts and your amazing work!

Luca

Hi Luca, it seems that the version of tidal connect you are using is not the latest. I know this because the logs have changed in the latest version. Please re-check if you are on 2.909. If you are on the latest version than something went wrong with the update. This can happen if files are changed in your filesystem, prior to the upgrade. Best solution is to do a factory reset.

Just to be sure i will check tomorrow if the x86 version of tidal connect was properly added to the latest image.

1 Like

Hi Mervinio,

Really thanks for your insights.

I wiped my usb drive and reinstalled the 2.909 and… wow, it finally works!

Probably something went wrong with the update. Quite strange as i edited only the triggerhappy conf file.

I tried this steps with the previous version with no luck in the past.

Thanks again;

Luca

Not aware that this has been looked at yet, AFAIK it isn’t yet working on Pi Zero.