Adding Snapcast to Volumio on RPi Zero W = no sound

I have tried installing SnapCast on a RPi Zero Wifi on the latest stable Volumio by using this:

git clone
cd volumio-snapcast-plugin/
volumio plugin install

and then following all instructions on Saiyato’s GitHub page. Everytime I do this on a clean install, my sound disappears. I have looked into asound.conf but I’m not really familiar with this kind of thing. The following log shows stack traces, seemingly caused by the same error every time:

I just can’t decide wether that error has something to do with SnapCast. I have also played with FIFO and ALSA output for MPD settings. Web radio does start to play and I am under the impression “sound”/data is being outputted somewhere, just not in the right place. Not sure if it’s important but I only have HDMI out. Which works perfectly fine with a fresh install and webradio. Does anyone have an idea?

Anyone? If have bought a couple of Pi Zero’s but I’m stuck :frowning:


Hi ppan,

I am having the same problem. Were you able to resolve it? Any pointers?