Adding CD Rom drive not working


I have a USB IBM Cd-rom drive (they are round discs that played music from 100 years ago, but I have a big collection). I have my virtuoso and selected the cd playback tab and obviously plugged it in to the volumio rpi 2b but its not starting or showing up. Is there anything else I need to do, and how would you normally press play, or would it just show up in the sources tab at the start UI?

Thanks, Tim

Hi Tim, just tried the CD playback and it works here. I have a Pi4 but i suppose that yours should work as well. Are you sure that the drive is OK?

Hi Panos,

Thanks for the reply… Yes the drive is fine, tested on another pc. I also tried another USB cd drive, but the same, nothing.
I’m guessing its maybe the coding saying its not installed or something. I dont know if its like a PC and just shows up with plugged in(?). Or maybe it doesn’t work with a RPi2.
How do you access and command your cd drive from volumio, i guess it shows up in sources and has a play button etc?

Cheers, Tim

Hi Tim, yes, it pops up after you insert a CD, shows together with the other sources

Hi Tim,

is that USB CD drive powered by USB only?
If yes, it could be that your Raspi’s USB ports don’t provide sufficient power for THIS CD drive to operate correctly. I have seen this happening on various PI and USB-CD/DVD drives.

Depending on the USB drive, there are several options then to solve the issue.

Hope this helps (sorry if not!), cheers, Thomas


Sorry for the slow reply. Well now I know what I’m looking for.
Actually I tried 2 and neither work. I always upgrade and have just done a reset to original settings which I thought might improve sound quality and the system didn’t sound as good as when I started and it did.
Anyway, they both have usb input but tale power separately from wall wart type psu so can’t be lack of power…