Accessing Volumio2 from outside LAN

Hi all,

I’ve been searching for solutions to this problem but so most of the stuff I found is related to Volumio 1.xx, so here’s my question.

With volumio1 I was doing the following: I have an account on a dynamic DNS website, and then I configured my home router to forward port 82 from the public internet IP to the port 80 of the static IP I assign to volumio. It just worked fine.

I recently upgraded to Volumio 2.041 and the port forwarding is not working anymore: if I access volumio from the LAN, everything works fine. If I access it via the dyndns address, I get and endless spinning wheel.

I found a post with the suggestion of changing /volumio/http/restapi.js, line 49 from
hostsarray.push(‘http://’+status.ipv4_address);
to
hostsarray.push(‘http://mydyndnshost.changeip.org’);
but it does not work…

Using Google Chrome network inspection I see that was is failing is the HTTP GET to:
http://127.0.0.1:3000/socket.io/?EIO=3&transport=polling&t=LfIPnfI

any suggestion?

Thanks,
Francesco

Volumio expects port 80, not 82.
So you either forward port 80 or you need to adapt /etc/iptables.rules to redirect from 82 to 3000
Could you try this?

– Gé –

Hi gkkpch,
thanks for your reply. I actually fixed a typo in my original message:

So all TCP packets dispatched to Volumio are actually seen by Volumio as directed to port 80.
The problem is that Volumio is then writing back the URL in some HTTP request apparently.
I tried looking again with Google Chrome developer mode at what is failing: from the browser located outside my LAN here’s the request that is failing:

http://192.168.1.98/socket.io/?EIO=3&transport=polling&t=Lfd1bm2

Note that 192.168.1.98 is the IP address that I assigned to Volumio in my LAN…of course however I cannot access that IP from outside the LAN. Basically what I would like to have in Volumio2 is the possibility to configure its public host address, so that it would write in such REST API request the correct URL:

http://mydyndnshost.changeip.org/socket.io/?EIO=3&transport=polling&t=Lfd1bm2

Do you think it would be possible to fix this in Volumio2?

Thanks,
Francesco