Accessing Music folder on external hard drive via router

Hi, I have three rpi’s in various parts of the house all running volumio (vers 3.378). For my needs, Volumio works very well and I am very pleased with it. However I have an issue that I have searched but found no simple explanation and I am hoping that someone might be able to explain, in simple steps if possible as I am not that tech savvy. I have an external hard drive which when plugged into either Rpi allows me to access my music files. What I would like to do is plug this hard drive into my router thus enabling all 3 pi’s to see my music files ( simple file sharing). The router is a TP Link AC 1750. I don’t imagine that this is rocket science however it is defeating me. Any advice would be warmly received.

please have a look here, to get started

I have four Raspberry Pis, all running Volumio.

I have a BT HomeHub router. I tried to attach a hard drive to the router so that all Pis could access it - failed.

I suggest the following fix:
Plug the HD into one of your RPis. This will serve as the master drive
In the “Sources” tab add it as a source “+New Drive”
Rescan and Update.
In your second RPi go to Source, Click on “+New Drive” you should see master drive that you have set up on the first Rpi and the path to the HD. Select, Update and Rescan.

Repeat for the third Rpi.

Essentially you are using the HD attached to one Pi as a media server.

I have also “mapped” my HD as a network drive on my PC so that I can transfer music files over my home network. That step is a bit more complex but not difficult.

If your router is connected to a Windows PC this may solve your problem. I found this on MS Support page and it allowed me to access my external drive connected to my new router. I have yet to connect my Pi to the new router and test if I still have access to the music library. One step at a time :slight_smile:

“If this works, what that tells me is that NETBIOS may be disabled for the network adapter on the Win10 machine.
You can check the NETBIOS setting as follows…
Control Panel > (select 'View by Large icons)
Network and Sharing Center
(In the left side column) select 'Change adapter settings
(Right-click the network adapter used for Internet access) select ‘Properties’ > (respond to the UAC prompt if necessary)
In the resulting form, select 'Internet Protocol Version 4 (TCP/IPv4) > Click ‘Properties’
In the next form, click on ‘Advanced’
Click on the WINS tab.
Hear you can select the Default, Enable or Disable settings for NETBIOS.”

I hope it helps.

Thanks for taking time to respond, I should have said we are a Mac house rather than windows😥

Thanks will do

Thanks for taking the time to answer. I am attempting to follow instructions but am failing at first hurdle. The hd shows up in my music obviously not in NAS

. When I go to 2nd RPi there is nothing. I have attempted this route before but no joy. I shall try all 3 in turn as ‘master drive’ Thanks again

Is it correct to assume that all your Rasp Pis are connected to the same rouuter?network?

This is how it looks on my network

Then when I select Raspberry PI - SMB/CIFS I get the dropdown that allows me to select the music folder:

Hi Jazzfan, Yes all on same router. I think that the issue might be smb/cifs. This is not something I have ever seen and so I searched and others have have an issue with this. I shall do more research into and see what emerges. Thanks again for advice

Hi Parko
I have occasionally had an issue with my Rasp Pis not “seeing” each other on the network. A simple fix is to turn each Pi off and then on again - use the Power Off tab in Volumio and then remove the power lead from the Pi. Reconnect and restart. Removing all the power seems to be the key step.

Hi Jazzfan, I’ve done my chores and will spend the next few hours trying to crack this :crossed_fingers: Watch this space