Access to volumio.local in different devices in the same network

Volumio Information

Volumio Version: 2.853
Hardware: Raspberry Pi 4B with Allo DigiOne Signature hat as sold by Allo already assembled as DigiOne Signature Player.

DAC: External SMSL SU-9; straight out to powered speakers.

Yeah, I know… yet another thread with volumio.local/ issues… Here’s the peculiarities of my case.

I have my DigiOne Signature player connected to the network with a LAN cable and is prefectly identified by both my Windows 10 computer and my Android phone using Spotify connect, This means the Pi is in the network and streams to my DAC and speakers using the Spotify app whitout issues. Also, both the computer and phone are connected to the network using the same wifi subnet.

If I open the browser in my computer and type volumio.local/ it opens my volumio page without issues. In contrast, volumio.local/ does not open in the Android phone (tried three different browsers) and gives me the error volumio.local’s DNS address not found. Have also tried with a different Android phone with the same result.

I take that if Spotify connect can see volumio in the network using both devices, it isn’t a network issue but a matter of configuring volumio such that both Android devices can be found.

Finally, notice that it is the first time I have a Pi and never used volumio before. Also, as the Allo DigiOne Signature player is a factory assembled and configured device, I didn’t have to deal with the regular Pi fiddling to install and configure volumio using commands, everything was already there. I only had to plug the device to the network, dac and power, and then open volumio.local in my computer browser to complete volumio config. If solutions require screen commands directly to the Pi card I will be lost since I am absolutely ignorant of all the usual jargon and procedures. So I appreciate soultions that do not require such actions, and if unavoidable, I will also be thankful for clear guidance for an absolute newcomer.

Thanks millions!

From Android, you need to use the IP address of your PI. It is not a Volumio limitation, but android uses Google DNS to resolve adresses, and it can’t resolve local one
You can use a app such a fing to find the IP.

Expanding on balbuze answer, you can go on your PC browser, open volumio.local, settings, network, and note the IP address. That’s the one to use on the Android device browser.

Thanks both to @balbuze and @vmiguel for the clear, simple and direct answers which of course worked perfectly. It would not be much for Volumio to provide such instructions in a very visible way so that absolute newbies can access their Pi easily. But heck, we can always turn to the community!

Thank you.

ps. This thread can be closed as answered.

.local on Android is a pain - try using your FQDN instead. You can find from your router, or from the pi with hostname -f

One more thing worth to mention. If your router is reset for whatever reason, and it is configured to assign IP dynamically, it will change the current IP of your Pi, so you need to go back and look for the current address designation. Shorcuts will only work until the router is reset.