A Cubox i4pro - DAC (8802 Tenor) USB Problem

Hi everybody,
as for the title I am experiencing problems trying to get my USB DAC working with Cubox i4 pro and Volumio.

I have already tried the Bearington solution reported here:

but there’s no way I can obtain the option to use USB audio in the MPD configuration screen nor I can see the card available with aplay -l (only spdif and hdmi).

My configuration is:
Cubox i 4pro with Volumio 1.4
Teac AH 01 (integrated Amplifier with Tenor 8802 as DAC USB input chip)

Any help anyone?

Many thanks!

I think the issue might be the chinese tenor 8802 chip, and whether the cubox-i usb drivers are compatible. For a $500 DAC to need specific usb drivers for windows makes me think that it’s got rather unusual requirements.

I don’t know if the Teac dac in async usb mode is capable of decoding up to 24/192 but I do know that the Cubox-i 4 running volumio isn’t capable of outputting them, via spdif nor hdmi , so you need to check the DACs async USB limits.

You could either dig around the tenor websites and see if there are clues as to how other people have solved the problem, this might mean doing some coding of volumio via ssh.
Connect the DAC to the Cubox-i by optical spdif.
get a USB to coxial spdif converter that does work with volumio/ cubox which would solve the 24/192 issue, and compatibility issue.

Thank you for the reply!

I’ll dig a litte bit around the Tenor website as you suggest.

I was more optimistic cause I’ve seen some users happy with a UD h01 by Teac which has the same USB chipset.
By optical spdif everything works just fine but decoding capabilities are rather limited this way.

By USB to coaxial do you mean something like the Hiface ?
Cost wise it will make sense to consider to buy a Raspberry if it’s less choosy on DACs…

What do you think?

Did you ever resolve this problem? I have the exact same setup, and haven’t been able to get my sound working. I’ve been following a lot of forum suggestions, trying to track down the problem, but don’t know enough linux to diagnose it myself. Starting with what I see in dmesg:

usb 1-1: new high speed USB device number 2 using fsl-ehci usb 1-1: config 1 has an invalid interface number: 3 but max is 2 usb 1-1: config 1 has an invalid interface number: 3 but max is 2 usb 1-1: config 1 has an invalid interface number: 3 but max is 2 usb 1-1: config 1 has no interface number 1 usb 1-1: device v0644 p8038 is not supported input: TEAC TEAC USB AUDIO DEVICE as /devices/platform/fsl-ehci.0/usb1/1-1/1-1:1.0/input/input1 generic-usb 0003:0644:8038.0001: input,hidraw0: USB HID v1.00 Device [TEAC TEAC USB AUDIO DEVICE] on usb-fsl-ehci.0-1/input0 Audio class v2 interfaces need an interface association snd-usb-audio: probe of 1-1:1.2 failed with error -5

It seems like maybe the place to start is with ALSA, to create the correct interface association, but I’m not sure…