5GHz network unavailable

Good afternoon! I have a raspberry pi 4 that should see a 5ghz network, but in the settings I only see a 2.4 network. Can I connect to a 5ghz network? Maybe it’s related to the region, but I haven’t found how to change it.

Yes unfortunately localisation support in Volumio doesn’t extend past the language.

You will need to manually set your wifi regulatory domain.
This can be done with:

sudo iw reg set  <CountryCode>

thank you for advice. While for me it is not quite clear, but I think I will figure out how to do it


I meant there is no option in the UI to set localization options beyond the language.

You will have to enable SSH and then enter the command above with your right region code.

Unfortunately, changing the region does not help, because the region depends not only on what is displayed in the raspberry, but also on what is in the router. And it is exposed by the provider. After the reboot, the region returns to the one where 5GHz does not work.

Not sure what you mean, but yes, the region needs to match your router…

I am assuming you changed the region, and then were able to connect to the router, but then after rebooting the Pi, you weren’t able to connect to the 5GHz network?

Would you share some system logs please?

One after you set the region, and then again after a reboot?

PS: I also assume you are using the Pi4’s internal WiFi and not some adapter?

I don’t know if I managed to make the logs correctly