2.246, UMC204HD, audio glitches, spotify sample rate


In the meantime I will switch back to using the Cubox-i. I installed V2.129 (which has some issues) and then used test mode to update it to V2.239 - this version is working very well (including spotify, after editing sound device in spopd.conf) and most importantly of all, no pops, clicks or dropouts at all in the sound. :sunglasses: The USB performance of imx6 is definitely superior to the Pi.

I will continue to follow up on the USB issue on the Pi though, hopefully this can also be solved.

This issue is being discussed here:


Looks like no progress has been made on this kernel issue over on the Github issue by the Raspberry Pi developers.

However a couple of observations - there is at least one report in that thread that the same USB audio dropout/glitch issue exists on x86 on 4.x kernels on USB 2 ports…

Also in the volumio 2 for cubox-i thread gkkpch is working on a Cubox-i build of Volumio using a 4.x (Armbian ?) kernel - and is also experiencing USB audio glitches and dropouts.

As I experience zero USB audio glitches on the current build of Volumio for Cubox-i which is based on a 3.14 kernel, it has got me thinking - is my Cubox-i only avoiding this issue because it is still on an old 3.14 kernel, and could this be a more generic problem with USB audio in 4.x kernels that can manifest on more than just the Raspberry Pi or even more than just arm ?

To test this theory, is there any easy way to get a test build of Volumio for Raspberry Pi 2 which is identical to the current stable version except for using a 3.14 kernel ? That would be very interesting to see if the glitches remain or not, and may help narrow down whether this is really a Pi problem or a more general 4.x kernel problem.

When the 4.x kernel series first came out I remember there were many nasty regressions on both Pi and Cubox-i that took a long while to be resolved.

I’ve offered for gkkpch to try our heavily patched OSMC 4.4.0 kernel sources for Cubox-i to see if this helps with the USB audio glitches, but I’m starting to wonder if that will actually help if its a more general 4.x kernel problem! (Unless one of our many patches does actually address it. There are so many I’m not sure)

I’ve given up on ever seeing this problem resolved - not volumio’s fault, but fundamental limitations of the USB controllers on the original models of Pi (Pi 1 through Pi 3) which result in lost USB packets with certain USB sound transfer modes as used by the UMC204HD.

However there is a glimmar of hope with the Raspberry Pi 4 which uses different USB controllers and drivers. Has anyone done any testing with the Pi 4 to see if this USB sound issue is solved there ?

I’m tempted to buy a 1GB Pi 4 to use for Volumio with my UMC204HD - and definitely would if it solves the USB dropouts/glitches problem in the audio - it would replace my Cubox-i which is not very well supported and kept up to date on Volumio.

Looks like the Pi foundation have officially given up trying to fix this issue as well: (Ticket closed with wont fix :wink: )

So basically “High-speed isochronous devices with a bInterval of 1” won’t work without dropouts on all Pi’s before the Pi 4, (which has a new USB controller) this probably includes most Audiophile USB DAC’s which support high sample rates and/or low latency modes.

Now that the Pi foundation have said this problem can’t be fixed I think anyone who wants to use a high quality USB DAC with Volumio who is hanging on to a Pi1, 2, 3 etc should just give up and move to a Pi 4 as there is no fix forthcoming.

I’ve been using my Pi 4 since it first came out with Volumio and the UMC204HD DAC and I’ve had zero problems with audible glitches.