2.001 release issues (webradio, spotify)


First of all I thank you for your amazing work. Volumio is a great HiFi platform.

This morning I flashed a new SD card for my raspberry with the new release (2.001)

However, I have encountered the following issues since this morning, without any success to resolve them:

  • Spotify is not in the search plugin list anymore. Impossible to get it
  • All webradios I add are not playing correctly : Error Falied to decode…
  • Top 500 Radios (Shoutcast), and By Genre (Souhtcast) buttons doesn’t seem to work anymore

And I use Volumio for Spotify and Webradios especially.
I try to find and download the previous release (August) to make my Raspberry+Volumio work again, but impossible to find it…

I thank you for advance for your help !



I would suggest trying flashing again.
I’m on the same version and webradio and Spotify works fine.
I used the update function. At first there was a problem with spotify but michelangelo fixed and after uninstall and reinstall plugin it worked.
I also have two other plugins available.


I’m sorry you’re having all this problems. To me they seem related to bad networking. Are you on wireless or wired?
Try rebooting and see if that helps.

I thank you both for your answers.

I flashed again with the 2.001 release, without improvements.
I managed to find the August release, and flashed it again : and it doesn’t work neither (exactly the same problems).

At home : August release OK
At my parents home : August and 2.001 releases : impossible to get webradios and spotify and other plugins.

=> Michelangelo you’re certainly right. It seems to be a network issue. The raspberry is wired, behind a router/modem (from our ISP).
Do you know what kind of protocol and/or port are used by volumio ?
The only networking process that works is the Dribble webradios.

Thank you again for your work :slight_smile:

Firstly, great work, Volumio is still awesome.

I have been having the same issues with Web radios - none of the web radios come up, same error as described above.

In addition, when I have imported web radio URLs from the previous version of Volumio 1.56 and RC2 they do not play and a message comes up to say they cannot be decoded.

Not sure it is related but when I go to the plugins menu none of the buttons have any effect and I cannot see any plugins at all.

Probably not related, when I try and list my music (on a 64GB USB stick) by Genre and the grid view comes up the Raspberry Pi reboots. I never see any album art on this screen.

I have re-flashed an 8GM SD card several times and get the same issues on a Raspberry Pi V3 and V2 (both model B). I have tried wireless and wired connections and the result is always the same.

Anyone have any ideas?

I have been trying to install the spotify plugin without any success.
it fails every time I try . Is there a way to manually install it from commandline? I am okay with linux and vi etc.

I managed to fix it. This may be helpful to someone:
looked at /var/log/volumio log and found the installer was failing due to non-default password. I had set the password of volumio user to something different than default.
I reset to default “volumio” and the installation of plugin went through, but it still did not work. It was inactive. Then I uninstalled the plugin and reinstalled it and rebooted to check it it worked. It worked!
I changed the password of volumio user after installing the plugin, that is not a problem anymore.

All this because I use the pi for other purposes as well. kind of a jump host to login my home system from outside and I changed a few things like setting key based ssh on the system etc. Anyone making customization need to be aware of the cascading effects of the changes to the system!

Big thanks to the creators and forum users. I get ideas from the forum users to troubleshoot if something does not work. I created an id and logged in just to update on the fix, in case someone finds it useful.


I installed version 2.001 on a PI2 yesterday and I have a problem importing my radio playlist from v1.55. The file is named Radios.m3u and its content is:

http://ice.somafm.com/cliqhop http://live.radio-campus.org:8000/toulouse http://streaming.prun.net/streamprun http://broadcast.infomaniak.net:80/alouette-high.mp3 http://audio.scdn.arkena.com/11006/franceinfo-midfi128.mp3 http://audio.scdn.arkena.com/11008/franceinter-midfi128.mp3
I do not have any network access problem (it works fine with Volumio 1.55 and VoyageMPD).
There are no entries displayed on the main screen but when I access the Pi thru MPDroid I can see my radios and play/stop/change them.

Any clue?

Has anyone resolved the original error reported in this post?

  • Spotify is not in the search plugin list anymore. Impossible to get it
  • All webradios I add are not playing correctly : Error Falied to decode…
  • Top 500 Radios (Shoutcast), and By Genre (Souhtcast) buttons doesn’t seem to work anymore

The issue you’re referring is due to a problem in internet connection.
This is a bug we can’t track down…
Are you connected on wireless or wired? Static ip or dhcp? Rebooting helps?

Have tried both wireless and wired connection. Have only tried it on DHCP. Works on the network at my Dad’s house, but not on mine. Have tried changing a few things on the router (putting the Pi in a DMZ) but still does not work. Same for my Pi 2 and Pi 3, both model B. Rebooting does not help. Old version of Volumio 1.55 works on same network without any issues.


had exactly the same problem but got it working :sunglasses:

No webradio, no plugins and the first time using Volumio made it difficult but this thread helped me. This is how I solved it:

  1. On Volumio website goto System - Factory reset. After a reboot it didn’t start anymore but stopped with PANIC Kernel error (don’t have the exact phrase anymore)
  2. Reprogrammed SD card with Volumio, reboot. Now it started correctly
  3. Changed /etc/network/interfaces with sudo nano /etc/network/interfaces and entered following:
    #iface eth0 inet dhcp
    iface eth0 inet static
    address (or whatever address you want Volumio to get)
    dns-nameservers (or whatever nameserver you have)
    dns-search <domain.tld> (your domain if you have one)
  4. sudo service networking restart
  5. ifconfig to verify address

Then volumio worked on :smiley:

Not sure what solved it but since webradio and plugins didn’t work before it looks like the gateway didn’t work.


Hum…pretty much looks like the DNS issue reported here, probably due to dnsmasq & dhcpd altering DNS operations at startup (like some routes un-properly set or prioritized conflicting with certain ISP/LAN setup), even if hotspot is not enabled.
Would be nice to get that sorted out, ensuring at least dnsmasq is only launched when hotspot is used (unsure dhcpd is really needed at all). Issue may still happen in hotspot operations, but this can be tracked separately.

While at it, lets’ also amend the auto eth0 and auto wlan0 statements in /etc/network/interface that create headaches to Pi Zero owners.

Have tried the suggestions above and webradios still do not work. The edited interface file is below, what am I missing here?

auto wlan0
#auto lo
#iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static

allow-hotplug wlan0
iface wlan0 inet manual
allow-hotplug wlan0
iface wlan0 inet manual

Instead of modifying /etc/network/interfaces, you may want to add the following lines to /etc/hosts: api.shoutcast.com yp.shoutcast.com
If your issue is with DNS, this may help.
You may get shoutcast service back, or some of it.
Please report.

Hi macmpi

I tried what you suggested on a brand new install of 2.031 and I can now get shoutcast. :smiley: :smiley:

On the fresh install plugins and dirble did not work. With your addition shoutcast now works by genre and the top 500 can be displayed. Many thanks - it has made Volumio usable for me again.

Interestingly, on the plugins page, when I select ‘Search Plugins’ it displays the Volumio IP address in the bottom left of the GUI - is this normal?

Webradio from Shoutcast can be added to the favorites and played successfully so this is a vast improvement.

The link to the Volumio shop works and opens a new window in the browser.

Looks like just the plugins and update that does not work.

Once again, thanks for your help, sorry it took so long to try it.

EDIT: just kept for historical reason. Real fix is 2 posts below.

Thought you may have to add api.dirble.com for drible too.

Now for Volumio stuff you may want to add the following: updates.volumio.org volumio.org volumio.github.io repo.volumio.org plugins.volumio.org but it may not work fully as installs & updates sometimes depends on apt-get and raspbian repos, which will not be resolved by this. You may need to also resolve some raspbian repo servers: not doing so may leave your device in undetermined state after failing updates or installs…

For Spotify, you might try those: accounts.spotify.com api.spotify.com ap.spotify.com but unsure this may be sufficient.

Now again, this is very hack-ish, and be prepared to remove them all, once this networking issue is fixed.
This one is very tricky as it seems to be highly ISP dependent (probably linked to dhcpd or dnsmasq setup).

One question: is hotspot enabled or not in your case?
How does your device connect to Internet, which interfaces?

Great, have just added all of these to the Hosts file and now have access to Dirble, updates and the plugins.

Tried previously with the hotspot enabled or disabled and the result was always the same.

Connect to the internet with an Edimax WiFi micro usb dongle but have also tried on a Pi 3 using the onboard WiFi and the result is the same. Have also tried a wired connection and the result is the same.

You may want to try this: it seems it fixed many similar issues (not a specific spotify plugin issue actually).
Will be part of next update by default.